aboutsummaryrefslogtreecommitdiffstats
path: root/community/plasma-pa/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/plasma-pa/APKBUILD')
-rw-r--r--community/plasma-pa/APKBUILD12
1 files changed, 5 insertions, 7 deletions
diff --git a/community/plasma-pa/APKBUILD b/community/plasma-pa/APKBUILD
index c6427c5556b..4954b31f975 100644
--- a/community/plasma-pa/APKBUILD
+++ b/community/plasma-pa/APKBUILD
@@ -1,8 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-pa
-pkgver=5.18.4
-_pkgver=5.18.4.1
+pkgver=5.18.5
pkgrel=0
pkgdesc="Plasma applet for audio volume management using PulseAudio"
arch="all !armhf" # armhf blocked by qt5-qtdeclarative
@@ -10,9 +9,8 @@ url="https://www.kde.org/workspaces/plasmadesktop/"
license="LGPL-2.1-only OR LGPL-3.0-only AND GPL-2.0-only"
depends="pulseaudio kirigami2"
makedepends="extra-cmake-modules qt5-qtbase-dev qt5-qtdeclarative-dev kcoreaddons-dev kdeclarative-dev kdoctools-dev kglobalaccel-dev knotifications-dev ki18n-dev plasma-workspace-dev pulseaudio-dev libcanberra-dev"
-source="https://download.kde.org/stable/plasma/$pkgver/plasma-pa-$_pkgver.tar.xz"
+source="https://download.kde.org/stable/plasma/$pkgver/plasma-pa-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
-builddir="$srcdir/$pkgname-$_pkgver"
build() {
cmake -B build \
@@ -20,7 +18,7 @@ build() {
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DUSE_GCONF=OFF
- make -C build
+ cmake --build build
}
check() {
@@ -29,6 +27,6 @@ check() {
}
package() {
- DESTDIR="$pkgdir" make -C build install
+ DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="877a861b7f3811958f911a082f037916697f148969229ed6d96c2ef7238533726157637548798ca318b5b1ee89cd5ed8f9a66fad2e8cb3e9035a5ee311cae7e3 plasma-pa-5.18.4.1.tar.xz"
+sha512sums="fff3049d4879e4f6fe428985dd14f91fa6bac8fe2e7c696ee1424d610038f61fd7eda2621bfd2c2643529956f7986b59c9eead1ceb79e1cfb1397fa52b470376 plasma-pa-5.18.5.tar.xz"