aboutsummaryrefslogtreecommitdiffstats
path: root/community/plasma-pass/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/plasma-pass/APKBUILD')
-rw-r--r--community/plasma-pass/APKBUILD30
1 files changed, 17 insertions, 13 deletions
diff --git a/community/plasma-pass/APKBUILD b/community/plasma-pass/APKBUILD
index 97e16c9c390..e184ef93ef2 100644
--- a/community/plasma-pass/APKBUILD
+++ b/community/plasma-pass/APKBUILD
@@ -1,31 +1,36 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-other
pkgname=plasma-pass
-pkgver=1.2.0
-pkgrel=1
+pkgver=1.2.2
+pkgrel=2
pkgdesc="Plasma applet for the Pass password manager"
# armhf blocked by qt5-qtdeclarative
-# s390x and riscv64 blocked by polkit -> plasma-framework
-arch="all !armhf !s390x !riscv64"
+arch="all !armhf"
url="https://kde.org/plasma-desktop/"
license="LGPL-2.1-or-later"
makedepends="
extra-cmake-modules
gpgme-dev
ki18n-dev
+ kio-dev
kitemmodels-dev
+ libplasma-dev
oath-toolkit-dev
- plasma-framework-dev
- qt5-qtbase-dev
- qt5-qtdeclarative-dev
+ plasma5support-dev
+ qt6-qtbase-dev
+ qt6-qtdeclarative-dev
samurai
"
-
-source="https://download.kde.org/stable/plasma-pass/plasma-pass-$pkgver.tar.xz"
subpackages="$pkgname-lang"
+_repo_url="https://invent.kde.org/plasma/plasma-pass.git"
+source="https://download.kde.org/stable/plasma-pass/plasma-pass-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
+ -DBUILD_WITH_QT6=ON \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
@@ -33,8 +38,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -42,5 +46,5 @@ package() {
}
sha512sums="
-4ac72af97a8026022459c46eb3d8dec1489dedf0ea47ab8c71a5ab92a9c5e2faca92ef2ed512e5cd0cc181a6aa7b6ab802ae98ce525e97818704e0bf58e4603a plasma-pass-1.2.0.tar.xz
+40a6ee175ff1801cee84947639414f3e01c1fc28ad08ef54bbf1b131ecb8239236274ef10ae6c0aab600ccdc25c17bca24a245e78506331d416ee6d9b5e874be plasma-pass-1.2.2.tar.xz
"