aboutsummaryrefslogtreecommitdiffstats
path: root/community/plasma-phonebook/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/plasma-phonebook/APKBUILD')
-rw-r--r--community/plasma-phonebook/APKBUILD37
1 files changed, 19 insertions, 18 deletions
diff --git a/community/plasma-phonebook/APKBUILD b/community/plasma-phonebook/APKBUILD
index 0fc6036d02f..5d62e5179df 100644
--- a/community/plasma-phonebook/APKBUILD
+++ b/community/plasma-phonebook/APKBUILD
@@ -1,33 +1,35 @@
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-mobile
pkgname=plasma-phonebook
-pkgver=22.04
-pkgrel=1
+pkgver=24.02.0
+pkgrel=0
pkgdesc="Contacts application which allows adding, modifying and removing contacts"
# armhf blocked by extra-cmake-modules
arch="all !armhf"
-url="https://invent.kde.org/kde/plasma-phonebook"
+url="https://invent.kde.org/plasma-mobile/plasma-phonebook"
license="LicenseRef-KDE-Accepted-GPL"
depends="
kirigami-addons
- kirigami2
- kpeoplevcard
- qt5-qtbase-sqlite
- qt5-qtquickcontrols
+ kirigami
+ qt6-qtbase-sqlite
"
makedepends="
extra-cmake-modules
kcontacts-dev
kcoreaddons-dev
- kirigami2-dev
+ kirigami-addons-dev
+ kirigami-dev
kpeople-dev
- kpeoplevcard-dev
- qt5-qtbase-dev
- qt5-qtdeclarative-dev
- qt5-qtquickcontrols2-dev
- qt5-qtsvg-dev
+ qt6-qtbase-dev
+ qt6-qtdeclarative-dev
+ qt6-qtsvg-dev
samurai
"
-source="https://download.kde.org/stable/plasma-mobile/$pkgver/plasma-phonebook-$pkgver.tar.xz"
+_repo_url="https://invent.kde.org/plasma-mobile/plasma-phonebook.git"
+source="https://download.kde.org/stable/plasma-phonebook/plasma-phonebook-$pkgver.tar.xz"
subpackages="$pkgname-lang"
options="!check" # No tests
@@ -40,8 +42,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -49,5 +50,5 @@ package() {
}
sha512sums="
-1974a40f357d1842f938302f200be6dca93b39efa72a3541db0847b3b5e1493f5fd62b41c01e05e568bbee61baea30235d4422976711d527ca716c78ad714ee0 plasma-phonebook-22.04.tar.xz
+e03aa6194e1d8797743924c55ea4f07a0d1cd1a3b49cbd051a3d7ef11b427b8046114975df63ad472598bebd02ff7296e707410fa56e902691b25cb96426d202 plasma-phonebook-24.02.0.tar.xz
"