aboutsummaryrefslogtreecommitdiffstats
path: root/community/plasma-phonebook/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/plasma-phonebook/APKBUILD')
-rw-r--r--community/plasma-phonebook/APKBUILD41
1 files changed, 23 insertions, 18 deletions
diff --git a/community/plasma-phonebook/APKBUILD b/community/plasma-phonebook/APKBUILD
index f37e07dfb0c..5d62e5179df 100644
--- a/community/plasma-phonebook/APKBUILD
+++ b/community/plasma-phonebook/APKBUILD
@@ -1,49 +1,54 @@
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-mobile
pkgname=plasma-phonebook
-pkgver=21.08
+pkgver=24.02.0
pkgrel=0
pkgdesc="Contacts application which allows adding, modifying and removing contacts"
# armhf blocked by extra-cmake-modules
arch="all !armhf"
-url="https://invent.kde.org/kde/plasma-phonebook"
+url="https://invent.kde.org/plasma-mobile/plasma-phonebook"
license="LicenseRef-KDE-Accepted-GPL"
depends="
- kirigami2
- qt5-qtbase-sqlite
- qt5-qtquickcontrols
+ kirigami-addons
+ kirigami
+ qt6-qtbase-sqlite
"
makedepends="
extra-cmake-modules
kcontacts-dev
kcoreaddons-dev
- kirigami2-dev
+ kirigami-addons-dev
+ kirigami-dev
kpeople-dev
- kpeoplevcard-dev
- qt5-qtbase-dev
- qt5-qtdeclarative-dev
- qt5-qtquickcontrols2-dev
- qt5-qtsvg-dev
+ qt6-qtbase-dev
+ qt6-qtdeclarative-dev
+ qt6-qtsvg-dev
+ samurai
"
-source="https://download.kde.org/stable/plasma-mobile/$pkgver/plasma-phonebook-$pkgver.tar.xz"
+_repo_url="https://invent.kde.org/plasma-mobile/plasma-phonebook.git"
+source="https://download.kde.org/stable/plasma-phonebook/plasma-phonebook-$pkgver.tar.xz"
subpackages="$pkgname-lang"
options="!check" # No tests
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
DESTDIR="$pkgdir" cmake --install build
}
+
sha512sums="
-0c78d0bf88a7678c6ca87fd548bbe6bc24c75358d7ef3250277b335ca1671b206188d686f0783bc59b7d58f3417d3fcaca21de0dac8c42f8396341db01626d24 plasma-phonebook-21.08.tar.xz
+e03aa6194e1d8797743924c55ea4f07a0d1cd1a3b49cbd051a3d7ef11b427b8046114975df63ad472598bebd02ff7296e707410fa56e902691b25cb96426d202 plasma-phonebook-24.02.0.tar.xz
"