aboutsummaryrefslogtreecommitdiffstats
path: root/community/plasma-sdk/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/plasma-sdk/APKBUILD')
-rw-r--r--community/plasma-sdk/APKBUILD43
1 files changed, 23 insertions, 20 deletions
diff --git a/community/plasma-sdk/APKBUILD b/community/plasma-sdk/APKBUILD
index 45128532bb0..d7c133d7fc2 100644
--- a/community/plasma-sdk/APKBUILD
+++ b/community/plasma-sdk/APKBUILD
@@ -1,18 +1,17 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-plasma
pkgname=plasma-sdk
-pkgver=5.22.5
+pkgver=6.0.3
pkgrel=0
pkgdesc="Applications useful for Plasma Development"
-# armhf blocked by qt5-qtdeclarative
-# mips64, s390x and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# armhf blocked by qt6-qtdeclarative
+arch="all !armhf"
url="https://kde.org/plasma-desktop/"
license="GPL-2.0-or-later"
-depends="
- kirigami2
- qt5-qtquickcontrols
- "
+depends="kirigami"
makedepends="
extra-cmake-modules
karchive-dev
@@ -26,14 +25,18 @@ makedepends="
ki18n-dev
kiconthemes-dev
kio-dev
+ kitemmodels-dev
kparts-dev
kservice-dev
+ ksvg-dev
ktexteditor-dev
kwidgetsaddons-dev
- plasma-framework-dev
- qt5-qtbase-dev
- qt5-qtdeclarative-dev
- qt5-qtsvg-dev
+ libplasma-dev
+ plasma5support-dev
+ qt6-qtbase-dev
+ qt6-qtdeclarative-dev
+ qt6-qtsvg-dev
+ samurai
"
checkdepends="xvfb-run"
@@ -41,21 +44,21 @@ case "$pkgver" in
*.90*) _rel=unstable;;
*) _rel=stable;;
esac
-source="https://download.kde.org/$_rel/plasma/$pkgver/plasma-sdk-$pkgver.tar.xz"
-subpackages="$pkgname-doc $pkgname-lang"
+subpackages="$pkgname-doc $pkgname-lang $pkgname-zsh-completion"
+_repo_url="https://invent.kde.org/plasma/plasma-sdk.git"
+source="https://download.kde.org/stable/plasma/$pkgver/plasma-sdk-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
# iconmodeltest is broken
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest -E "iconmodeltest"
+ xvfb-run -a ctest --test-dir build --output-on-failure -E "iconmodeltest"
}
package() {
@@ -63,5 +66,5 @@ package() {
}
sha512sums="
-893bf785994537068efe5f8c854c2bd9a650849029822a5790b3874e2137eeac4f587185e571471494a47551c60e8b395520e125b8e2f511f36f6f483867671e plasma-sdk-5.22.5.tar.xz
+094f5fb9f806b97aaccdc9471d16ccd4817250d04576e5c8c93e2f919a39e9aca8a962de01c0a743f4feb1b35b44645045c6fb022a79c63ebbc996ca2e586023 plasma-sdk-6.0.3.tar.xz
"