aboutsummaryrefslogtreecommitdiffstats
path: root/community/plasma-systemmonitor/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/plasma-systemmonitor/APKBUILD')
-rw-r--r--community/plasma-systemmonitor/APKBUILD34
1 files changed, 21 insertions, 13 deletions
diff --git a/community/plasma-systemmonitor/APKBUILD b/community/plasma-systemmonitor/APKBUILD
index 89059c55acb..aa2a7c6fbde 100644
--- a/community/plasma-systemmonitor/APKBUILD
+++ b/community/plasma-systemmonitor/APKBUILD
@@ -1,15 +1,20 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-plasma
pkgname=plasma-systemmonitor
-pkgver=5.22.5
+pkgver=6.0.3
pkgrel=0
pkgdesc="An application for monitoring system resources"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf"
url="https://kde.org/plasma-desktop/"
license="LicenseRef-KDE-Accepted-GPL AND LicenseRef-KDE-Accepted-LGPL AND CC0-1.0"
-depends="kirigami2"
+depends="
+ kirigami
+ ksystemstats
+ "
makedepends="
extra-cmake-modules
kconfig-dev
@@ -18,38 +23,41 @@ makedepends="
kglobalaccel-dev
ki18n-dev
kio-dev
+ kirigami-addons-dev
kitemmodels-dev
knewstuff-dev
kservice-dev
libksysguard-dev
- qt5-qtbase-dev
- qt5-qtdeclarative-dev
+ qt6-qtbase-dev
+ qt6-qtdeclarative-dev
+ samurai
"
case "$pkgver" in
*.90*) _rel=unstable;;
*) _rel=stable;;
esac
-source="https://download.kde.org/$_rel/plasma/$pkgver/plasma-systemmonitor-$pkgver.tar.xz"
subpackages="$pkgname-lang"
+_repo_url="https://invent.kde.org/plasma/plasma-systemmonitor.git"
+source="https://download.kde.org/stable/plasma/$pkgver/plasma-systemmonitor-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
# ksystemstatstest is broken
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest -E "ksystemstatstest"
+ ctest --test-dir build --output-on-failure -E "ksystemstatstest"
}
package() {
DESTDIR="$pkgdir" cmake --install build
}
+
sha512sums="
-4116be820038318022efe6d7460d7deef2983940dac7ab1949aa0c8d18473b15d9de41f21241c63342656b5871c1a2291daa3ff0d576849fa27177425419013c plasma-systemmonitor-5.22.5.tar.xz
+3e4b7f8178c7c774eae0fe9daff7f1fe346a242af32e245676d36ab4bb46d557d5806d3255beeda8e4c7ba60dd697ec43188fac82903a65cd2ca2de75baa4c48 plasma-systemmonitor-6.0.3.tar.xz
"