aboutsummaryrefslogtreecommitdiffstats
path: root/community/plasma-thunderbolt/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/plasma-thunderbolt/APKBUILD')
-rw-r--r--community/plasma-thunderbolt/APKBUILD35
1 files changed, 20 insertions, 15 deletions
diff --git a/community/plasma-thunderbolt/APKBUILD b/community/plasma-thunderbolt/APKBUILD
index 75d11bf9001..139c437368e 100644
--- a/community/plasma-thunderbolt/APKBUILD
+++ b/community/plasma-thunderbolt/APKBUILD
@@ -1,11 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-plasma
pkgname=plasma-thunderbolt
-pkgver=5.22.5
+pkgver=6.0.4
pkgrel=0
-# armhf blocked by qt5-qtdeclarative
-# s390x, mips64 and riscv64 blocked by bolt -> polkit
-arch="all !armhf !s390x !mips64 !riscv64"
+# armhf blocked by qt6-qtdeclarative
+arch="all !armhf"
url="https://kde.org/plasma-desktop/"
pkgdesc="Plasma integration for controlling Thunderbolt devices"
license="GPL-2.0-only OR GPL-3.0-only"
@@ -18,30 +20,33 @@ makedepends="
kdeclarative-dev
ki18n-dev
knotifications-dev
- qt5-qtbase-dev
- qt5-qtdeclarative-dev
+ qt6-qtbase-dev
+ qt6-qtdeclarative-dev
+ samurai
+ "
+checkdepends="
+ dbus
+ xvfb-run
"
-checkdepends="xvfb-run"
case "$pkgver" in
*.90*) _rel=unstable;;
*) _rel=stable;;
esac
-source="https://download.kde.org/$_rel/plasma/$pkgver/plasma-thunderbolt-$pkgver.tar.xz"
subpackages="$pkgname-lang"
-options="!check" # Requires running dbus server
+_repo_url="https://invent.kde.org/plasma/plasma-thunderbolt.git"
+source="https://download.kde.org/stable/plasma/$pkgver/plasma-thunderbolt-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
+ dbus-run-session -- xvfb-run -a ctest --test-dir build --output-on-failure -E "(libkbolt-device|kbolt-kded-kded)test"
}
package() {
@@ -49,5 +54,5 @@ package() {
}
sha512sums="
-abc492c6a69cd3a2efa82c798d9a5e178f08fac098cd68055308f5bb4459e16914210e119e50838dd5af8d2240ead47e1dcfb06cb49a9a8d4e4ee6c0ba386581 plasma-thunderbolt-5.22.5.tar.xz
+119f6af9088dc108ccee9e0ba83d2a357f25a561f774f7ac88282fc8716594fa38d7d2b125cb19fbff9055498b4187f7c7ea7dcf146e8d2103109652df63a936 plasma-thunderbolt-6.0.4.tar.xz
"