aboutsummaryrefslogtreecommitdiffstats
path: root/community/plasma-wayland-protocols/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/plasma-wayland-protocols/APKBUILD')
-rw-r--r--community/plasma-wayland-protocols/APKBUILD28
1 files changed, 19 insertions, 9 deletions
diff --git a/community/plasma-wayland-protocols/APKBUILD b/community/plasma-wayland-protocols/APKBUILD
index 6c1193110fc..c6756518e4f 100644
--- a/community/plasma-wayland-protocols/APKBUILD
+++ b/community/plasma-wayland-protocols/APKBUILD
@@ -1,19 +1,28 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-other
pkgname=plasma-wayland-protocols
-pkgver=1.3.0
-pkgrel=0
+pkgver=1.12.0
+pkgrel=1
pkgdesc="Plasma Specific Protocols for Wayland"
-arch="noarch !armhf" # armhf blocked by extra-cmake-modules
+# armhf blocked by extra-cmake-modules
+arch="noarch !armhf"
url="https://www.kde.org/plasma-desktop/"
license="GPL-2.0-or-later AND (GPL-2.0-only OR GPL-3.0-only) AND LGPL-2.1-only"
-makedepends="extra-cmake-modules"
+makedepends="
+ extra-cmake-modules
+ qt6-qttools-dev
+ samurai
+ "
+_repo_url="https://invent.kde.org/libraries/plasma-wayland-protocols.git"
source="https://download.kde.org/stable/plasma-wayland-protocols/plasma-wayland-protocols-$pkgver.tar.xz"
-options="!check" # No tests
+options="!check" # No code to test
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
@@ -22,6 +31,7 @@ build() {
package() {
DESTDIR="$pkgdir" cmake --install build
}
+
sha512sums="
-4c0466bbbe07399d4c54d4f04d7bee92826a6009c61fd7e6898c04d12e906c68fce25c520583225aef18737071b71b85814070a769a4f00e2a71b709568c1695 plasma-wayland-protocols-1.3.0.tar.xz
+4894493e117669d7ab54b385e2a40d69ddce7cb860b68d9a28f9032d63cad6004858f984ad8ece34567e0e806ccb3f973852596b905d2618b60115ccf9c82886 plasma-wayland-protocols-1.12.0.tar.xz
"