aboutsummaryrefslogtreecommitdiffstats
path: root/community/plasma-workspace-wallpapers/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/plasma-workspace-wallpapers/APKBUILD')
-rw-r--r--community/plasma-workspace-wallpapers/APKBUILD28
1 files changed, 19 insertions, 9 deletions
diff --git a/community/plasma-workspace-wallpapers/APKBUILD b/community/plasma-workspace-wallpapers/APKBUILD
index 1a64f59d2ce..ae8038ab7ca 100644
--- a/community/plasma-workspace-wallpapers/APKBUILD
+++ b/community/plasma-workspace-wallpapers/APKBUILD
@@ -1,24 +1,34 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-plasma
pkgname=plasma-workspace-wallpapers
-pkgver=5.23.1
+pkgver=6.0.4
pkgrel=0
pkgdesc="Wallpapers for the Plasma Workspace"
-arch="noarch !armhf" # armhf blocked by extra-cmake-modules
+# armhf blocked by extra-cmake-modules
+arch="noarch !armhf"
url="https://kde.org/plasma-desktop/"
license="GPL-2.0-or-later"
-makedepends="extra-cmake-modules"
+makedepends="
+ extra-cmake-modules
+ qt6-qttools-dev
+ samurai
+ "
case "$pkgver" in
*.90*) _rel=unstable;;
*) _rel=stable;;
esac
-source="https://download.kde.org/$_rel/plasma/$pkgver/plasma-workspace-wallpapers-$pkgver.tar.xz"
-options="!check" # No tests available
+_repo_url="https://invent.kde.org/plasma/plasma-workspace-wallpapers.git"
+source="https://download.kde.org/stable/plasma/$pkgver/plasma-workspace-wallpapers-$pkgver.tar.xz"
+# No tests available
+options="!check"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
@@ -29,5 +39,5 @@ package() {
}
sha512sums="
-2f6fbaf90888311fb679f0b0c593aeffeb9faeb1292403a33460b40d0ab38e9a52a606b8ed2ff0957962f439b17ab803ad550dc16092f2173ceebf35319cb7ed plasma-workspace-wallpapers-5.23.1.tar.xz
+8a6233319e9a6d480f025a4d92b2289820e62417df69b22ccaa911790eefbf14e98de844d27aa498d3a099f309fc1d70e9fb3bd11721d781f58cefc82238bfab plasma-workspace-wallpapers-6.0.4.tar.xz
"