aboutsummaryrefslogtreecommitdiffstats
path: root/community/plasma-workspace-wallpapers/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/plasma-workspace-wallpapers/APKBUILD')
-rw-r--r--community/plasma-workspace-wallpapers/APKBUILD24
1 files changed, 17 insertions, 7 deletions
diff --git a/community/plasma-workspace-wallpapers/APKBUILD b/community/plasma-workspace-wallpapers/APKBUILD
index 78b0d57d468..3caf72e698d 100644
--- a/community/plasma-workspace-wallpapers/APKBUILD
+++ b/community/plasma-workspace-wallpapers/APKBUILD
@@ -1,20 +1,30 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-plasma
pkgname=plasma-workspace-wallpapers
-pkgver=5.25.2
+pkgver=6.0.3
pkgrel=0
pkgdesc="Wallpapers for the Plasma Workspace"
-arch="noarch !armhf" # armhf blocked by extra-cmake-modules
+# armhf blocked by extra-cmake-modules
+arch="noarch !armhf"
url="https://kde.org/plasma-desktop/"
license="GPL-2.0-or-later"
-makedepends="extra-cmake-modules samurai"
+makedepends="
+ extra-cmake-modules
+ qt6-qttools-dev
+ samurai
+ "
case "$pkgver" in
*.90*) _rel=unstable;;
*) _rel=stable;;
esac
-source="https://download.kde.org/$_rel/plasma/$pkgver/plasma-workspace-wallpapers-$pkgver.tar.xz"
-options="!check" # No tests available
+_repo_url="https://invent.kde.org/plasma/plasma-workspace-wallpapers.git"
+source="https://download.kde.org/stable/plasma/$pkgver/plasma-workspace-wallpapers-$pkgver.tar.xz"
+# No tests available
+options="!check"
build() {
cmake -B build -G Ninja \
@@ -29,5 +39,5 @@ package() {
}
sha512sums="
-bcecdaeead5a6b0a31f5c31776932e5015b4ada0bf4930952593a553db5842063ce42be1d1553fc0e5f26def5442c85199651374839e9dc76104a599aa7ef236 plasma-workspace-wallpapers-5.25.2.tar.xz
+44a2433f20241f0e745bc72ab8c9bc6f5ddb0160eee4c6bbdcde089b51b891edd4d2917c4e25f4e2e93ded3ccd0712025d0d51954bed245f6a2684771303137a plasma-workspace-wallpapers-6.0.3.tar.xz
"