aboutsummaryrefslogtreecommitdiffstats
path: root/community/pluma/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/pluma/APKBUILD')
-rw-r--r--community/pluma/APKBUILD35
1 files changed, 28 insertions, 7 deletions
diff --git a/community/pluma/APKBUILD b/community/pluma/APKBUILD
index 02a4b0066c6..54841750360 100644
--- a/community/pluma/APKBUILD
+++ b/community/pluma/APKBUILD
@@ -1,19 +1,32 @@
# Contributor: Alan Lacerda <alacerda@alpinelinux.org>
# Maintainer: Alan Lacerda <alacerda@alpinelinux.org>
pkgname=pluma
-pkgver=1.22.2
+pkgver=1.26.1
pkgrel=0
pkgdesc="A small and lightweight UTF-8 text editor for the MATE"
url="https://github.com/mate-desktop/pluma"
-arch="all !s390x" # mate-desktop
+arch="all"
license="GPL-2.0-or-later"
# check fails as tracked in https://github.com/mate-desktop/pluma/issues/33
options="!check"
depends="mate-desktop"
-makedepends="intltool enchant-dev iso-codes-dev gtk+3.0-dev
- mate-desktop-dev gtksourceview-dev dconf-dev libsm-dev itstool
- libxml2-utils fortify-headers libpeas-dev gsettings-desktop-schemas-dev"
-subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+makedepends="
+ dconf-dev
+ enchant2-dev
+ fortify-headers
+ gsettings-desktop-schemas-dev
+ gtk+3.0-dev
+ gtksourceview-dev
+ gtksourceview4-dev
+ intltool
+ iso-codes-dev
+ itstool
+ libpeas-dev
+ libsm-dev
+ libxml2-utils
+ mate-desktop-dev
+ "
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang $pkgname-pyc"
source="https://pub.mate-desktop.org/releases/${pkgver%.*}/pluma-$pkgver.tar.xz"
build() {
@@ -34,4 +47,12 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="a68b79713f649def15ea29e58e041d70bb6d756a356743f6e06d8dd680f7b39e8bcdd90c68cbe5c517bead7f9263d7596954bc595c3a2501edf0d0ea421c9992 pluma-1.22.2.tar.xz"
+pyc() {
+ default_pyc
+ local IFS=$'\n'
+ amove $(find usr/lib/pluma -type d -name __pycache__)
+}
+
+sha512sums="
+bc4f621736d93df07fc2dc434a25c5a5acaf0d2c958eac43bd0061d4b664cae9b9eac1fffc47afa1509fd64b3c93a77ca62737428b034ca25997ebee432d5eb3 pluma-1.26.1.tar.xz
+"