aboutsummaryrefslogtreecommitdiffstats
path: root/community/plymouth-kcm/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/plymouth-kcm/APKBUILD')
-rw-r--r--community/plymouth-kcm/APKBUILD49
1 files changed, 36 insertions, 13 deletions
diff --git a/community/plymouth-kcm/APKBUILD b/community/plymouth-kcm/APKBUILD
index e728e85f9ee..6a623430f0d 100644
--- a/community/plymouth-kcm/APKBUILD
+++ b/community/plymouth-kcm/APKBUILD
@@ -1,33 +1,56 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-plasma
pkgname=plymouth-kcm
-pkgver=5.18.5
+pkgver=6.0.3
pkgrel=0
-arch="all !armhf" # armhf blocked by extra-cmake-modules
-url="https://cgit.kde.org/plymouth-kcm.git"
+# armhf blocked by extra-cmake-modules
+arch="all !armhf"
+url="https://invent.kde.org/plasma/plymouth-kcm"
pkgdesc="KCM to manage the Plymouth (Boot) theme"
license="GPL-2.0-or-later"
depends="plymouth"
-makedepends="extra-cmake-modules qt5-qtbase-dev karchive-dev knewstuff-dev kio-dev kdeclarative-dev ki18n-dev kconfig-dev kconfigwidgets-dev plymouth-dev kcmutils"
-source="https://download.kde.org/stable/plasma/$pkgver/plymouth-kcm-$pkgver.tar.xz"
+makedepends="
+ extra-cmake-modules
+ karchive-dev
+ kcmutils-dev
+ kconfig-dev
+ kconfigwidgets-dev
+ kdeclarative-dev
+ ki18n-dev
+ kio-dev
+ knewstuff-dev
+ plymouth-dev
+ qt6-qtbase-dev
+ samurai
+ "
+
+case "$pkgver" in
+ *.90*) _rel=unstable;;
+ *) _rel=stable;;
+esac
subpackages="$pkgname-lang"
-options="!check" # No tests
+_repo_url="https://invent.kde.org/plasma/plymouth-kcm.git"
+source="https://download.kde.org/stable/plasma/$pkgver/plymouth-kcm-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="ab9c883d4ed23315e925884662c72b42b350a1938b7dcf24dc30e0486fdd4c4449dcdc30abc45b3007d586e07998c96834918d2e91fcda3163c0f9f5b62c37cf plymouth-kcm-5.18.5.tar.xz"
+sha512sums="
+98cb633c52ef88392b96dd03799b609e3a5533bb6c79d30c626d39babae2b58fa2fc520ac9c662012d37fc3e4856ec9e0ee67c29e49ec83ee71ada4628fb92c5 plymouth-kcm-6.0.3.tar.xz
+"