aboutsummaryrefslogtreecommitdiffstats
path: root/community/plymouth-kcm/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/plymouth-kcm/APKBUILD')
-rw-r--r--community/plymouth-kcm/APKBUILD28
1 files changed, 15 insertions, 13 deletions
diff --git a/community/plymouth-kcm/APKBUILD b/community/plymouth-kcm/APKBUILD
index 19eea77f159..6a623430f0d 100644
--- a/community/plymouth-kcm/APKBUILD
+++ b/community/plymouth-kcm/APKBUILD
@@ -1,11 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-plasma
pkgname=plymouth-kcm
-pkgver=5.23.2
+pkgver=6.0.3
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf"
url="https://invent.kde.org/plasma/plymouth-kcm"
pkgdesc="KCM to manage the Plymouth (Boot) theme"
license="GPL-2.0-or-later"
@@ -13,7 +15,7 @@ depends="plymouth"
makedepends="
extra-cmake-modules
karchive-dev
- kcmutils
+ kcmutils-dev
kconfig-dev
kconfigwidgets-dev
kdeclarative-dev
@@ -21,28 +23,28 @@ makedepends="
kio-dev
knewstuff-dev
plymouth-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
+ samurai
"
case "$pkgver" in
*.90*) _rel=unstable;;
*) _rel=stable;;
esac
-source="https://download.kde.org/$_rel/plasma/$pkgver/plymouth-kcm-$pkgver.tar.xz"
subpackages="$pkgname-lang"
-options="!check" # No tests
+_repo_url="https://invent.kde.org/plasma/plymouth-kcm.git"
+source="https://download.kde.org/stable/plasma/$pkgver/plymouth-kcm-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -50,5 +52,5 @@ package() {
}
sha512sums="
-d073941c4fc9815576e9fc93b2d9a13f79ec03e82cf639aa2ddb9ebf3dca645760dd92da81e565d16d7cb830b89a44047bfce1ab197cc237f597bae26daaa794 plymouth-kcm-5.23.2.tar.xz
+98cb633c52ef88392b96dd03799b609e3a5533bb6c79d30c626d39babae2b58fa2fc520ac9c662012d37fc3e4856ec9e0ee67c29e49ec83ee71ada4628fb92c5 plymouth-kcm-6.0.3.tar.xz
"