aboutsummaryrefslogtreecommitdiffstats
path: root/community/plymouth-kcm/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/plymouth-kcm/APKBUILD')
-rw-r--r--community/plymouth-kcm/APKBUILD23
1 files changed, 12 insertions, 11 deletions
diff --git a/community/plymouth-kcm/APKBUILD b/community/plymouth-kcm/APKBUILD
index 7b4b3142aba..6a623430f0d 100644
--- a/community/plymouth-kcm/APKBUILD
+++ b/community/plymouth-kcm/APKBUILD
@@ -1,11 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-plasma
pkgname=plymouth-kcm
-pkgver=5.24.5
+pkgver=6.0.3
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !riscv64"
+arch="all !armhf"
url="https://invent.kde.org/plasma/plymouth-kcm"
pkgdesc="KCM to manage the Plymouth (Boot) theme"
license="GPL-2.0-or-later"
@@ -13,7 +15,7 @@ depends="plymouth"
makedepends="
extra-cmake-modules
karchive-dev
- kcmutils
+ kcmutils-dev
kconfig-dev
kconfigwidgets-dev
kdeclarative-dev
@@ -21,7 +23,7 @@ makedepends="
kio-dev
knewstuff-dev
plymouth-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
samurai
"
@@ -29,9 +31,9 @@ case "$pkgver" in
*.90*) _rel=unstable;;
*) _rel=stable;;
esac
-source="https://download.kde.org/$_rel/plasma/$pkgver/plymouth-kcm-$pkgver.tar.xz"
subpackages="$pkgname-lang"
-options="!check" # No tests
+_repo_url="https://invent.kde.org/plasma/plymouth-kcm.git"
+source="https://download.kde.org/stable/plasma/$pkgver/plymouth-kcm-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
@@ -42,8 +44,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -51,5 +52,5 @@ package() {
}
sha512sums="
-7bc78c3b3d2639de00f428bda606b4f822c99f4c3dc0c2f1fe3f422208e05273701a1871fc573c36b8e14cc1a8bc02e07e4389a40b3fee3a6b79c44a561c2cf8 plymouth-kcm-5.24.5.tar.xz
+98cb633c52ef88392b96dd03799b609e3a5533bb6c79d30c626d39babae2b58fa2fc520ac9c662012d37fc3e4856ec9e0ee67c29e49ec83ee71ada4628fb92c5 plymouth-kcm-6.0.3.tar.xz
"