aboutsummaryrefslogtreecommitdiffstats
path: root/community/podman/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/podman/APKBUILD')
-rw-r--r--community/podman/APKBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/community/podman/APKBUILD b/community/podman/APKBUILD
index 890660ed5fc..534b1d8d620 100644
--- a/community/podman/APKBUILD
+++ b/community/podman/APKBUILD
@@ -34,6 +34,7 @@ subpackages="
$pkgname-bash-completion
$pkgname-fish-completion
$pkgname-zsh-completion
+ $pkgname-remote:remote
$pkgname-docker:docker:noarch
$pkgname-docker-doc:docker_doc:noarch
"
@@ -52,11 +53,11 @@ source="https://github.com/containers/podman/archive/v$pkgver/podman-$pkgver.tar
build() {
export BUILDTAGS="exclude_graphdriver_devicemapper seccomp apparmor"
- make podman docs
+ make podman podman-remote docs
}
package() {
- make install.bin install.man-nobuild install.completions install.cni \
+ make install.bin install.remote install.man-nobuild install.completions install.cni \
PREFIX=/usr DESTDIR="$pkgdir"
install -Dm755 "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
@@ -71,6 +72,11 @@ package() {
rm -r "$pkgdir"/usr/lib/tmpfiles.d
}
+remote() {
+ pkgdesc="Remote CLI for Podman"
+ amove usr/bin/podman-remote
+}
+
docker() {
pkgdesc="Emulate Docker CLI using Podman"
depends="podman"