aboutsummaryrefslogtreecommitdiffstats
path: root/community/poedit
diff options
context:
space:
mode:
Diffstat (limited to 'community/poedit')
-rw-r--r--community/poedit/APKBUILD7
-rw-r--r--community/poedit/fix-missing-include.patch25
2 files changed, 30 insertions, 2 deletions
diff --git a/community/poedit/APKBUILD b/community/poedit/APKBUILD
index 63662a0fdf8..fdd2ebc6361 100644
--- a/community/poedit/APKBUILD
+++ b/community/poedit/APKBUILD
@@ -12,7 +12,9 @@ makedepends="boost-dev enchant2-dev gtk+3.0-dev gtkspell3-dev
lucene++-dev wxgtk3-dev autoconf automake libtool pugixml-dev
gettext-dev"
subpackages="$pkgname-lang $pkgname-doc"
-source="https://github.com/vslavik/poedit/archive/v$pkgver-oss.tar.gz"
+source="https://github.com/vslavik/poedit/archive/v$pkgver-oss.tar.gz
+ fix-missing-include.patch
+ "
builddir="$srcdir/$pkgname-$pkgver-oss"
prepare() {
@@ -41,4 +43,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="03dc34835838f91358e9093634cf1a293b076f301c248a76ead26dc7446b4f4712a5079ac7116b3183f73e53681f920007abdada118318dadd4f17503ca4b078 v2.4.2-oss.tar.gz"
+sha512sums="03dc34835838f91358e9093634cf1a293b076f301c248a76ead26dc7446b4f4712a5079ac7116b3183f73e53681f920007abdada118318dadd4f17503ca4b078 v2.4.2-oss.tar.gz
+4a03c13baa577a46a77b8b8c2ea13dbfeb4dc5313e39d2d8b12869a74be4ee396138aa3e2e29d57460dac53f2eee12ca7a22d471163482a1b87b211d2b5da85d fix-missing-include.patch"
diff --git a/community/poedit/fix-missing-include.patch b/community/poedit/fix-missing-include.patch
new file mode 100644
index 00000000000..c8f1f5c4d33
--- /dev/null
+++ b/community/poedit/fix-missing-include.patch
@@ -0,0 +1,25 @@
+From 281f93b29190c67c86c4403b96efdbac957a0162 Mon Sep 17 00:00:00 2001
+From: rezso <rezso@rezso.net>
+Date: Sun, 15 Nov 2020 00:11:49 +0100
+Subject: [PATCH] Add missing include
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Fix ' concurrency.h:606:10: error: ‘atomic_bool’ in namespace ‘std’ does not name a type; did you mean ‘atomic_load’? ' build error.
+---
+ src/concurrency.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/concurrency.h b/src/concurrency.h
+index df806f1eae..ceca909e9a 100644
+--- a/src/concurrency.h
++++ b/src/concurrency.h
+@@ -67,6 +67,7 @@
+ #endif
+ #endif
+
++#include <atomic>
+ #include <memory>
+ #include <mutex>
+