aboutsummaryrefslogtreecommitdiffstats
path: root/community/poetry
diff options
context:
space:
mode:
Diffstat (limited to 'community/poetry')
-rw-r--r--community/poetry/APKBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/community/poetry/APKBUILD b/community/poetry/APKBUILD
index 1d5b4f53cdc..b6ec462f861 100644
--- a/community/poetry/APKBUILD
+++ b/community/poetry/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Michał Polański <michal@polanski.me>
pkgname=poetry
pkgver=1.1.13
-pkgrel=1
+pkgrel=2
pkgdesc="Python3 dependency management and packaging system"
url="https://python-poetry.org"
license="MIT"
@@ -30,7 +30,7 @@ depends="
py3-lark-parser
py3-jsonschema
"
-makedepends="py3-build py3-pip"
+makedepends="py3-build py3-installer"
source="$pkgname-$pkgver.tar.gz::https://github.com/sdispater/poetry/archive/$pkgver.tar.gz
fix-packaging-tags.patch
"
@@ -48,7 +48,7 @@ build() {
}
package() {
- python3 -m pip install --no-deps --root "$pkgdir" --no-warn-script-location \
+ python3 -m installer -d "$pkgdir" --compile-bytecode 0 \
dist/poetry-$pkgver-py2.py3-none-any.whl
# remove conflicts with files owned by py3-poetry-core (direct dependency of poetry)