aboutsummaryrefslogtreecommitdiffstats
path: root/community/polari/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/polari/APKBUILD')
-rw-r--r--community/polari/APKBUILD45
1 files changed, 29 insertions, 16 deletions
diff --git a/community/polari/APKBUILD b/community/polari/APKBUILD
index 18fcee5d674..6f6dc24106e 100644
--- a/community/polari/APKBUILD
+++ b/community/polari/APKBUILD
@@ -1,28 +1,42 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=polari
-pkgver=41.0
-pkgrel=0
+pkgver=45.0
+pkgrel=1
pkgdesc="Polari is a simple IRC Client that is designed to integrate seamlessly with GNOME 3"
url="https://wiki.gnome.org/Apps/Polari"
-arch="all !s390x !riscv64" # limited by gjs
+arch="all !armhf !s390x" # limited by gjs
license="GPL-2.0-or-later"
-depends="telepathy-logger telepathy-idle telepathy-mission-control gspell"
-makedepends="meson gobject-introspection-dev gtk+3.0-dev telepathy-glib-dev
- gjs-dev itstool"
-checkdepends="appstream-glib mozjs78 desktop-file-utils"
-subpackages="$pkgname-lang $pkgname-doc"
-source="https://download.gnome.org/sources/polari/${pkgver%.*}/polari-$pkgver.tar.xz
- merge_file-args.patch
+depends="
+ telepathy-logger
+ telepathy-idle
+ telepathy-mission-control
+ libadwaita
+ libsecret
+ libsoup3
+ "
+makedepends="
+ desktop-file-utils
+ gjs-dev
+ gobject-introspection-dev
+ gtk+3.0-dev
+ itstool
+ meson
+ telepathy-glib-dev
"
+checkdepends="appstream-glib"
+subpackages="$pkgname-lang $pkgname-doc"
+source="https://download.gnome.org/sources/polari/${pkgver%.*}/polari-$pkgver.tar.xz"
build() {
- abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ abuild-meson -Db_lto=true . output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
+ LD_LIBRARY_PATH="$PWD/output/src" \
+ meson devenv -C output polari --version # check for runtime dependencies
}
package() {
@@ -30,6 +44,5 @@ package() {
}
sha512sums="
-98ae67b36a0a47bc536ce87668b3e9f7144c0196b520d7ac3885f9a6ca158027ec2afe1e9d8a8e29b2bcc55a0109f7cfbe17582ebc22f59250175c49dac71919 polari-41.0.tar.xz
-da18a01a09f2c9b0d79028df6cd1b1d5f44650c96c63ab16f9cccd0df35a5058931f8ef0372db5012c98fd886f7de93f31f3a8d930642329f922b23bc59c9077 merge_file-args.patch
+33a3a0ef6960d2ac11fc312efc859a5ea75198c4ae8e74ff0885f9d0aa04f4e59d84be1495db3f498486b595aac66a91ec63d121a92557d9386dfbaed60bb409 polari-45.0.tar.xz
"