aboutsummaryrefslogtreecommitdiffstats
path: root/community/polkit-kde-agent-1/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/polkit-kde-agent-1/APKBUILD')
-rw-r--r--community/polkit-kde-agent-1/APKBUILD32
1 files changed, 21 insertions, 11 deletions
diff --git a/community/polkit-kde-agent-1/APKBUILD b/community/polkit-kde-agent-1/APKBUILD
index da60f92ec23..31701632078 100644
--- a/community/polkit-kde-agent-1/APKBUILD
+++ b/community/polkit-kde-agent-1/APKBUILD
@@ -1,12 +1,14 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-plasma
pkgname=polkit-kde-agent-1
-pkgver=5.21.1
+pkgver=6.0.4
pkgrel=0
pkgdesc="Daemon providing a polkit authentication UI for KDE"
# armhf blocked by extra-cmake-modules
-# mips, mips64, s390x blocked by polkit-qt-1
-arch="all !armhf !s390x !mips !mips64"
+arch="all !armhf"
url="https://kde.org/plasma-desktop/"
license="GPL-2.0-or-later"
depends="polkit-elogind"
@@ -19,21 +21,24 @@ makedepends="
kiconthemes-dev
kwidgetsaddons-dev
kwindowsystem-dev
- polkit-qt-1-dev
- qt5-qtbase-dev
+ polkit-qt-dev
+ qt6-qtbase-dev
+ samurai
"
case "$pkgver" in
*.90*) _rel=unstable;;
*) _rel=stable;;
esac
-source="https://download.kde.org/$_rel/plasma/$pkgver/polkit-kde-agent-1-$pkgver.tar.xz"
subpackages="$pkgname-lang"
-options="!check" # No tests
+_repo_url="https://invent.kde.org/plasma/polkit-kde-agent-1.git"
+source="https://download.kde.org/stable/plasma/$pkgver/polkit-kde-agent-1-$pkgver.tar.xz"
+# No tests
+options="!check"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
@@ -41,6 +46,11 @@ build() {
package() {
DESTDIR="$pkgdir" cmake --install build
+
+ # We don't ship systemd
+ rm -r "$pkgdir"/usr/lib/systemd
}
-sha512sums="b159c0f1f6762d7da656257ec765bce3ce5b0a1abdf2780a3862a7ba86c3e2297c500179afbf7520ae0e0b959732d6ea92f5f20de0286df5fecd5b6e50f9a183 polkit-kde-agent-1-5.21.1.tar.xz"
+sha512sums="
+7f5a3c0f3283caf6b669a237980d5cec8774d0fcbc5512b37981c146b5da19aec97374e6288ceffe5f257021bc0765562f84c57bf2de9c0940413a3b06182c91 polkit-kde-agent-1-6.0.4.tar.xz
+"