aboutsummaryrefslogtreecommitdiffstats
path: root/community/polkit-kde-agent-1/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/polkit-kde-agent-1/APKBUILD')
-rw-r--r--community/polkit-kde-agent-1/APKBUILD27
1 files changed, 16 insertions, 11 deletions
diff --git a/community/polkit-kde-agent-1/APKBUILD b/community/polkit-kde-agent-1/APKBUILD
index c231d5f062d..31701632078 100644
--- a/community/polkit-kde-agent-1/APKBUILD
+++ b/community/polkit-kde-agent-1/APKBUILD
@@ -1,12 +1,14 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-plasma
pkgname=polkit-kde-agent-1
-pkgver=5.21.5
+pkgver=6.0.4
pkgrel=0
pkgdesc="Daemon providing a polkit authentication UI for KDE"
# armhf blocked by extra-cmake-modules
-# mips, mips64, s390x blocked by polkit-qt-1
-arch="all !armhf !s390x !mips !mips64"
+arch="all !armhf"
url="https://kde.org/plasma-desktop/"
license="GPL-2.0-or-later"
depends="polkit-elogind"
@@ -19,21 +21,24 @@ makedepends="
kiconthemes-dev
kwidgetsaddons-dev
kwindowsystem-dev
- polkit-qt-1-dev
- qt5-qtbase-dev
+ polkit-qt-dev
+ qt6-qtbase-dev
+ samurai
"
case "$pkgver" in
*.90*) _rel=unstable;;
*) _rel=stable;;
esac
-source="https://download.kde.org/$_rel/plasma/$pkgver/polkit-kde-agent-1-$pkgver.tar.xz"
subpackages="$pkgname-lang"
-options="!check" # No tests
+_repo_url="https://invent.kde.org/plasma/polkit-kde-agent-1.git"
+source="https://download.kde.org/stable/plasma/$pkgver/polkit-kde-agent-1-$pkgver.tar.xz"
+# No tests
+options="!check"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
@@ -47,5 +52,5 @@ package() {
}
sha512sums="
-840e63d962054e6be2204f0ca5142249338050a1d3df3db66667275ae3fb1930bd3d9f4ea37b85feee73b33822c8b34015028b981d7a100afeaab793f1525ea9 polkit-kde-agent-1-5.21.5.tar.xz
+7f5a3c0f3283caf6b669a237980d5cec8774d0fcbc5512b37981c146b5da19aec97374e6288ceffe5f257021bc0765562f84c57bf2de9c0940413a3b06182c91 polkit-kde-agent-1-6.0.4.tar.xz
"