aboutsummaryrefslogtreecommitdiffstats
path: root/community/polybar/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/polybar/APKBUILD')
-rw-r--r--community/polybar/APKBUILD23
1 files changed, 11 insertions, 12 deletions
diff --git a/community/polybar/APKBUILD b/community/polybar/APKBUILD
index a44a6e05658..9b099682d34 100644
--- a/community/polybar/APKBUILD
+++ b/community/polybar/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Taner Tas <taner76@gmail.com>
# Maintainer: Taner Tas <taner76@gmail.com>
pkgname=polybar
-pkgver=3.5.6
-pkgrel=1
+pkgver=3.6.3
+pkgrel=0
pkgdesc="fast and easy-to-use tool for creating status bars"
url="https://polybar.github.io/"
arch="all"
@@ -16,9 +16,11 @@ makedepends="
jsoncpp-dev
libmpdclient-dev
libnl3-dev
+ libuv-dev
libxcb-dev
pulseaudio-dev
python3
+ py3-sphinx
xcb-proto
xcb-util-cursor-dev
xcb-util-image-dev
@@ -34,20 +36,16 @@ subpackages="
install="
$pkgname.post-install
"
-_xppver="c1a0f59cf262f88eccb276c9bcd5bcee8c410971"
-_i3ipcppver="cb008b30fc5f3febfe467884cb0211ee3c16386b"
+_xppver="044e69d05db7f89339bda1ccd1efe0263b01c8f6"
+_i3ipcppver="86ddf7102c6903ae0cc543071e2d375403fc0727"
source="
$pkgname-$pkgver.tar.gz::https://github.com/polybar/polybar/archive/$pkgver.tar.gz
xpp-$_xppver.tar.gz::https://github.com/polybar/xpp/archive/$_xppver.tar.gz
i3ipcpp-$_i3ipcppver.tar.gz::https://github.com/polybar/i3ipcpp/archive/$_i3ipcppver.tar.gz
+ fix-version.patch
"
options="!check" # No test suite
-# temp allow textrels on riscv64
-case $CARCH in
- riscv64) options="$options textrels";;
-esac
-
prepare() {
mkdir -p build
rm -rf lib/xpp
@@ -69,7 +67,8 @@ package() {
}
sha512sums="
-5022f7876489cc28805a52894c8ea42c2afc0600c84f6ce27f1a7c738fcc48fbf5f5d5537472378eae4f3d5ca36fc2fc8b069b379e35b1047d12a3b294e1857f polybar-3.5.6.tar.gz
-d83eaadb31f3cf044e446bc92ad8bf3c627554f012cf2f1b62eb9dab1ae8a0ab2f338e264377c157444c3f742a9ca45b9a4184a29f6b7eabaa0554067e957cd0 xpp-c1a0f59cf262f88eccb276c9bcd5bcee8c410971.tar.gz
-27a90d80f2de45743c2347be5ec5c88db58c4f3bb2aa44093c2a1e3178bfd5761ec806bdec9c6b6a4de6d1e67d5f14d4518e99611bf7e2984cfc880898357133 i3ipcpp-cb008b30fc5f3febfe467884cb0211ee3c16386b.tar.gz
+cdb1851b2b9a7e503dc9d9377f60be12573d171b64e7e053cec943e229b730f1034ff47cfc9ca246cd32089b2ef7595bc198ac91e93cbfbf24f7ad2bebef5d4e polybar-3.6.3.tar.gz
+646e159d47d6dac8f08a27a1cb54e2ef48e42cff952b55b3906c2021c424e015c070a31a7a1e70b62e0edc7a8b42b935a23b9a922eaab138d3f6929bc1fdb8d4 xpp-044e69d05db7f89339bda1ccd1efe0263b01c8f6.tar.gz
+f4643bea5a78bd9518fecc9d56ece8d679539b99016440a6e4d45305984c02963d80e00c5375cc53ac7418e2f24f57279930428b331e077eaafa8d0717677662 i3ipcpp-86ddf7102c6903ae0cc543071e2d375403fc0727.tar.gz
+02186474284b1fc9c3054f7ea92645e20269d067326b035791bc6e50df2fc928fa287723ca249386bec557e36de2e71c9978c2bbf0cb8b2e3b5ecdcdf0e6fcd4 fix-version.patch
"