aboutsummaryrefslogtreecommitdiffstats
path: root/community/portfolio/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/portfolio/APKBUILD')
-rw-r--r--community/portfolio/APKBUILD23
1 files changed, 11 insertions, 12 deletions
diff --git a/community/portfolio/APKBUILD b/community/portfolio/APKBUILD
index 8e82e8a9f42..afe3ff4bb6a 100644
--- a/community/portfolio/APKBUILD
+++ b/community/portfolio/APKBUILD
@@ -1,42 +1,41 @@
# Contributor: Clayton Craft <clayton@craftyguy.net>
# Maintainer: Clayton Craft <clayton@craftyguy.net>
pkgname=portfolio
-pkgver=0.9.10
-pkgrel=2
+pkgver=1.0.1
+pkgrel=1
pkgdesc="Minimalist file manager for those who want to use Linux mobile devices"
url="https://github.com/tchx84/Portfolio"
-# riscv64 disabled due to missing rust in recursive dependency
-arch="noarch !s390x !mips64 !riscv64" # no libhandy1 on s390x and mips64
+arch="noarch"
license="GPL-3.0-or-later"
depends="
- gtk+3.0
- libhandy1
+ gtk4.0
+ libadwaita
py3-gettext
py3-gobject3
"
makedepends="
gettext-dev
glib-dev
+ libadwaita-dev
meson
py3-setuptools
"
source="
$pkgname-$pkgver.tar.gz::https://github.com/tchx84/Portfolio/archive/v$pkgver.tar.gz
- 0001-places-handle-cases-where-XDG_-dirs-couldnt-be-resolve.patch
- 0002-fall-back-to-gettext-module-on-systems-that.patch
"
options="!check" # no tests
+subpackages="$pkgname-lang"
builddir="$srcdir/Portfolio-$pkgver"
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
package() {
DESTDIR="$pkgdir" meson install -C output
}
-sha512sums="5182c88bc5d00f8f307cf6c23f636a1e4d9fdd79e662cd6a1cb90c80380b9108df0fe5f07f6dd79df40fa14a57dbeeafb324a83961e399d07b5c6bef0007558d portfolio-0.9.10.tar.gz
-dcb14f6d41f7cc1540e6d1341d35e18f10ab1167c65e8b6c2e57acd97656d51e6c036876467b0110ef46c1cf4834c9d54d2e82797dabd6e565718014739ccdf9 0001-places-handle-cases-where-XDG_-dirs-couldnt-be-resolve.patch
-4e6e504b550161fa7c40258926c5f7e98418403d26512399ecceb75613b75b0a1a3707e04fb31bc54c7cd84b5af2c055421222fdbff545e8798076415e81cc8c 0002-fall-back-to-gettext-module-on-systems-that.patch"
+sha512sums="
+ef297550bee61862bf17b8ffd4170dc4d7a1205a2006783ff27bb96f22427f2da322b1e4633472084b05365bb1d2201bd554cfb385412e535a58000a8c062c03 portfolio-1.0.1.tar.gz
+"