aboutsummaryrefslogtreecommitdiffstats
path: root/community/postgresql-orafce/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/postgresql-orafce/APKBUILD')
-rw-r--r--community/postgresql-orafce/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/community/postgresql-orafce/APKBUILD b/community/postgresql-orafce/APKBUILD
new file mode 100644
index 00000000000..0c91d20391d
--- /dev/null
+++ b/community/postgresql-orafce/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=postgresql-orafce
+_pkgname=orafce
+pkgver=3.4.0
+_pkgver=VERSION_${pkgver//./_}
+pkgrel=0
+pkgdesc="Oracle's compatibility functions and packages for PostgreSQL"
+url="https://github.com/orafce/orafce"
+arch="all"
+license="BSD"
+depends="postgresql"
+makedepends="bison flex postgresql-dev"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/orafce/$_pkgname/archive/$_pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$_pkgver"
+options="!check" # XXX: installcheck requires running PostgreSQL
+
+build() {
+ cd "$builddir"
+ make USE_PGXS=1 all
+}
+
+package() {
+ cd "$builddir"
+
+ make USE_PGXS=1 DESTDIR="$pkgdir" install
+
+ cd "$pkgdir"
+ mv ./usr/share/doc/postgresql/extension \
+ ./usr/share/doc/$pkgname
+ rmdir ./usr/share/doc/postgresql
+}
+
+sha512sums="576fd6d818528d6fa980a911b355fe31b131d87f5d758a78eab4f9c47546d039ae93ca6ac253312b3828da91147ae8c852685ed312a5f9ad02b8fc53b55a9e42 postgresql-orafce-3.4.0.tar.gz"