aboutsummaryrefslogtreecommitdiffstats
path: root/community/postgresql-sequential-uuids/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/postgresql-sequential-uuids/APKBUILD')
-rw-r--r--community/postgresql-sequential-uuids/APKBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/community/postgresql-sequential-uuids/APKBUILD b/community/postgresql-sequential-uuids/APKBUILD
index c96ebddaac8..2c3beea5452 100644
--- a/community/postgresql-sequential-uuids/APKBUILD
+++ b/community/postgresql-sequential-uuids/APKBUILD
@@ -2,18 +2,15 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=postgresql-sequential-uuids
_projname=sequential-uuids
-pkgver=1.0.1
-# Upstream doesn't use tags yet (https://github.com/tvondra/sequential-uuids/issues/7).
-_gitrev=665d5b18d17d9f3922b17facadedbcd8aefe1524
+pkgver=1.0.2
pkgrel=1
pkgdesc="Generator of sequential UUIDs for PostgreSQL"
url="https://github.com/tvondra/sequential-uuids"
arch="all"
license="MIT"
-depends="postgresql"
makedepends="postgresql-dev"
-source="https://github.com/tvondra/sequential-uuids/archive/$_gitrev/$pkgname-$pkgver.tar.gz"
-builddir="$srcdir/$_projname-$_gitrev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/tvondra/sequential-uuids/archive/refs/tags/v$pkgver.tar.gz"
+builddir="$srcdir/$_projname-$pkgver"
options="!check" # no tests provided
build() {
@@ -21,7 +18,11 @@ build() {
}
package() {
+ depends="postgresql$(pg_config --major-version)"
+
make DESTDIR="$pkgdir" install
}
-sha512sums="38818b815b9f2c23dde717f4efcc76a933d5cccf4da5a674d8ad72d0a92a9482e3f0286cb51e193dc0ff2d36b5b284154b7ce55126e5d07e9a9b4bad7c078bc7 postgresql-sequential-uuids-1.0.1.tar.gz"
+sha512sums="
+8329532da047f94cd729607c826729fa27eaeb25b02b0685bdf24167993341ef497aec990e8b161d2117031fab0e7fa0198636b631a02053cbcb41d3a65e012d postgresql-sequential-uuids-1.0.2.tar.gz
+"