aboutsummaryrefslogtreecommitdiffstats
path: root/community/postgresql-timescaledb/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/postgresql-timescaledb/APKBUILD')
-rw-r--r--community/postgresql-timescaledb/APKBUILD42
1 files changed, 24 insertions, 18 deletions
diff --git a/community/postgresql-timescaledb/APKBUILD b/community/postgresql-timescaledb/APKBUILD
index 7acce4ea74f..fa4b43dbfca 100644
--- a/community/postgresql-timescaledb/APKBUILD
+++ b/community/postgresql-timescaledb/APKBUILD
@@ -1,57 +1,63 @@
# Contributor: wener <wenermail@gmail.com>
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: wener <wenermail@gmail.com>
-#
-# Keep in sync with non-free/postgresql-timescaledb-tsl.
-#
pkgname=postgresql-timescaledb
-_projname=timescaledb
-pkgver=2.4.1
-pkgrel=1
+pkgver=2.14.1
+pkgrel=0
pkgdesc="PostgreSQL extension for time‑series data"
url="https://github.com/timescale/timescaledb"
arch="all"
license="Apache-2.0"
provides="timescaledb=$pkgver-r$pkgrel" # for backward compatibility
-makedepends="postgresql-dev cmake bash perl-ipc-run perl-utils"
+makedepends="
+ bash
+ cmake
+ openssl-dev>3
+ perl-ipc-run
+ perl-utils
+ postgresql
+ postgresql-dev
+ samurai
+ "
install="$pkgname.post-install $pkgname.post-upgrade"
source="https://github.com/timescale/timescaledb/archive/$pkgver/postgresql-timescaledb-$pkgver.tar.gz
- dont-use-git-describe.patch
fix-build.patch
"
-builddir="$srcdir/$_projname-$pkgver"
+builddir="$srcdir/timescaledb-$pkgver"
options="!check" # FIXME: see comment on REGRESS_CHECKS=OFF below
+# secfixes:
+# 2.9.3-r0:
+# - CVE-2023-25149
+
export USE_PGXS=1
build() {
- # CFLAGS - performance is more important than binary size in this case
# REGRESS_CHECKS=OFF - disable regress test
# regress need https://github.com/timescale/timescaledb/blob/master/test/pg_isolation_regress.sh
# which need to compile pg - https://github.com/timescale/timescaledb/issues/1655#issuecomment-578683986
- # CMAKE_BUILD_TYPE - note that 'None' doesn't work here!
# APACHE_ONLY - we cannot provide non-free software in Alpine repos;
# users can build TSL module themselves with aport non-free/postgresql-timescaledb-tsl.
- cmake -B build . \
+ cmake -B build -G Ninja \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_C_FLAGS_RELEASE="${CFLAGS/-Os/-O2} -DNDEBUG" \
-DCMAKE_VERBOSE_MAKEFILE=ON \
-DREGRESS_CHECKS=OFF \
-DAPACHE_ONLY=ON
- make -C build
+ cmake --build build
}
check() {
- make -C build test
+ cmake --build build --target test
}
package() {
- make -C build install DESTDIR="$pkgdir"
+ depends="postgresql$(pg_config --major-version)"
+
+ DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
-54baced28eb20aa14c78605ce7828f7c48210125d9193c3e1c88e9ae81616b2baf37a1eb97c5eb0ddc9b6820d534d134ad047f3c7ace374e29191a42142f35a1 postgresql-timescaledb-2.4.1.tar.gz
-1416d7314fb6bc9c115587c86dabb2aff01a4c7e6e9ae842e5021276c21c61c9db4e73e6e0b1732af1b15419218248228447822b3f08e38729a08aaf8d99b521 dont-use-git-describe.patch
+c9e4e55068b191694f8341e2452e2b8a79fc6aa8ea6d818a2b464a156bf7357471616c2de13aa7dd29d6b6c34eb58763f8835af38102b1372695f559334bd359 postgresql-timescaledb-2.14.1.tar.gz
fe542830c3aad330c6c1da6e83cc308d749787f7ef7bb23eec7e834f1264aa2ca93b9e272f34c92b42dbb5ca9ea93e311831dd5910d6ac8e9afbc92725439eaf fix-build.patch
"