aboutsummaryrefslogtreecommitdiffstats
path: root/community/poxml/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/poxml/APKBUILD')
-rw-r--r--community/poxml/APKBUILD29
1 files changed, 19 insertions, 10 deletions
diff --git a/community/poxml/APKBUILD b/community/poxml/APKBUILD
index 8cfe6ad6662..7b5101dcb1a 100644
--- a/community/poxml/APKBUILD
+++ b/community/poxml/APKBUILD
@@ -1,33 +1,42 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=poxml
-pkgver=21.08.2
+pkgver=24.02.1
pkgrel=0
arch="all !armhf !riscv64"
url="https://www.kde.org/applications/development/"
pkgdesc="Translates DocBook XML files using gettext po files"
license="GPL-2.0-or-later AND GFDL-1.2-only"
-makedepends="extra-cmake-modules qt5-qtbase-dev kdoctools-dev gettext-dev"
-source="https://download.kde.org/stable/release-service/$pkgver/src/poxml-$pkgver.tar.xz"
+makedepends="
+ extra-cmake-modules
+ gettext-dev
+ kdoctools5-dev
+ qt5-qtbase-dev
+ samurai
+ "
subpackages="$pkgname-doc"
+_repo_url="https://invent.kde.org/sdk/poxml.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/poxml-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
-9f6c065bdaa2862b97bf7d299257a654974fd9cdc261ac4f61164ae23dfdfbbc7c9f83f9b2ba3ed70ae01223f37a1f2abc3827f41ac79703be40f1c9523e9337 poxml-21.08.2.tar.xz
+a562f4d7b11c380de1d5a55c2f0a076a3f5dfc828845eedff55730efa7b6cb4329f75905b9c55316b387eb102e27ed4b7696a2f976e37c2fb381f6afbc547d7d poxml-24.02.1.tar.xz
"