aboutsummaryrefslogtreecommitdiffstats
path: root/community/poxml/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/poxml/APKBUILD')
-rw-r--r--community/poxml/APKBUILD25
1 files changed, 17 insertions, 8 deletions
diff --git a/community/poxml/APKBUILD b/community/poxml/APKBUILD
index f8bb81e1491..bc9679095f6 100644
--- a/community/poxml/APKBUILD
+++ b/community/poxml/APKBUILD
@@ -1,15 +1,25 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=poxml
-pkgver=22.04.2
+pkgver=24.02.2
pkgrel=0
arch="all !armhf !riscv64"
url="https://www.kde.org/applications/development/"
pkgdesc="Translates DocBook XML files using gettext po files"
license="GPL-2.0-or-later AND GFDL-1.2-only"
-makedepends="extra-cmake-modules qt5-qtbase-dev kdoctools-dev gettext-dev samurai"
-source="https://download.kde.org/stable/release-service/$pkgver/src/poxml-$pkgver.tar.xz"
+makedepends="
+ extra-cmake-modules
+ gettext-dev
+ kdoctools5-dev
+ qt5-qtbase-dev
+ samurai
+ "
subpackages="$pkgname-doc"
+_repo_url="https://invent.kde.org/sdk/poxml.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/poxml-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
@@ -20,14 +30,13 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
-eaceb11a46d6a325ff8fdbdc98501ab7e27754051a10e4716ac5b06a1e7c962bd814fb6e25500675fe2f163f211452de4825ef1c2e864ef87f6ed81350c318c5 poxml-22.04.2.tar.xz
+94552451f0f85fb1928c61cb3a6e41e64736ed463b0201e0ffe750f7a38e5849532f669368de59b00dbe57f18a56dde48fcb1adf231862a66ecc3092e180f37c poxml-24.02.2.tar.xz
"