aboutsummaryrefslogtreecommitdiffstats
path: root/community/print-manager/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/print-manager/APKBUILD')
-rw-r--r--community/print-manager/APKBUILD33
1 files changed, 18 insertions, 15 deletions
diff --git a/community/print-manager/APKBUILD b/community/print-manager/APKBUILD
index 122e0f0ce8b..fa8a3dc4f92 100644
--- a/community/print-manager/APKBUILD
+++ b/community/print-manager/APKBUILD
@@ -1,11 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-plasma
pkgname=print-manager
-pkgver=21.08.1
+pkgver=6.0.3
pkgrel=0
-# armhf blocked by qt5-qtdeclarative
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# armhf blocked by qt6-qtdeclarative
+arch="all !armhf"
url="https://www.kde.org/applications/utilities/"
pkgdesc="A tool for managing print jobs and printers"
license="GPL-2.0-or-later"
@@ -20,28 +22,29 @@ makedepends="
ki18n-dev
kiconthemes-dev
kio-dev
+ kirigami-addons-dev
knotifications-dev
kwidgetsaddons-dev
kwindowsystem-dev
- plasma-framework-dev
- qt5-qtbase-dev
- qt5-qtdeclarative-dev
+ libplasma-dev
+ qt6-qtbase-dev
+ qt6-qtdeclarative-dev
+ samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/print-manager-$pkgver.tar.xz"
subpackages="$pkgname-lang"
-options="!check" # No tests available
+_repo_url="https://invent.kde.org/utilities/print-manager.git"
+source="https://download.kde.org/stable/plasma/$pkgver/print-manager-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -49,5 +52,5 @@ package() {
}
sha512sums="
-bb4525edfa878561b69c0c4ec30a245ca691e73e2839e0687207efc8f52fa55631eb9a5cdaeb0bed91753cd57ea1e3a562eebfdad9ada336c7536350d2e0168d print-manager-21.08.1.tar.xz
+4159e0482eb72e26b3bacf267511bb50783fd89fe68a3d31e377d901c53792717247ca350073914d579fe65ea25ee6f438f5251b5f1a230dd8dec4fedb9f4127 print-manager-6.0.3.tar.xz
"