aboutsummaryrefslogtreecommitdiffstats
path: root/community/print-manager/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/print-manager/APKBUILD')
-rw-r--r--community/print-manager/APKBUILD28
1 files changed, 15 insertions, 13 deletions
diff --git a/community/print-manager/APKBUILD b/community/print-manager/APKBUILD
index aede3ae94a1..fa8a3dc4f92 100644
--- a/community/print-manager/APKBUILD
+++ b/community/print-manager/APKBUILD
@@ -1,11 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-plasma
pkgname=print-manager
-pkgver=22.04.2
+pkgver=6.0.3
pkgrel=0
-# armhf blocked by qt5-qtdeclarative
-# s390x and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !riscv64"
+# armhf blocked by qt6-qtdeclarative
+arch="all !armhf"
url="https://www.kde.org/applications/utilities/"
pkgdesc="A tool for managing print jobs and printers"
license="GPL-2.0-or-later"
@@ -20,17 +22,18 @@ makedepends="
ki18n-dev
kiconthemes-dev
kio-dev
+ kirigami-addons-dev
knotifications-dev
kwidgetsaddons-dev
kwindowsystem-dev
- plasma-framework-dev
- qt5-qtbase-dev
- qt5-qtdeclarative-dev
+ libplasma-dev
+ qt6-qtbase-dev
+ qt6-qtdeclarative-dev
samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/print-manager-$pkgver.tar.xz"
subpackages="$pkgname-lang"
-options="!check" # No tests available
+_repo_url="https://invent.kde.org/utilities/print-manager.git"
+source="https://download.kde.org/stable/plasma/$pkgver/print-manager-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
@@ -41,8 +44,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -50,5 +52,5 @@ package() {
}
sha512sums="
-707066111db1ac3a22004d0ccaba28e7bd52349bcbd1fb70bb171d5bd6de3ffd5dd167e4036afd62c376af773cd2185aa938419e158f2261bca30bea00de7fc1 print-manager-22.04.2.tar.xz
+4159e0482eb72e26b3bacf267511bb50783fd89fe68a3d31e377d901c53792717247ca350073914d579fe65ea25ee6f438f5251b5f1a230dd8dec4fedb9f4127 print-manager-6.0.3.tar.xz
"