aboutsummaryrefslogtreecommitdiffstats
path: root/community/print-manager/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/print-manager/APKBUILD')
-rw-r--r--community/print-manager/APKBUILD30
1 files changed, 16 insertions, 14 deletions
diff --git a/community/print-manager/APKBUILD b/community/print-manager/APKBUILD
index 2982b2c43fb..42efc8f62c8 100644
--- a/community/print-manager/APKBUILD
+++ b/community/print-manager/APKBUILD
@@ -1,11 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-plasma
pkgname=print-manager
-pkgver=22.04.0
-pkgrel=1
-# armhf blocked by qt5-qtdeclarative
-# s390x and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !riscv64"
+pkgver=6.0.4
+pkgrel=0
+# armhf blocked by qt6-qtdeclarative
+arch="all !armhf"
url="https://www.kde.org/applications/utilities/"
pkgdesc="A tool for managing print jobs and printers"
license="GPL-2.0-or-later"
@@ -20,17 +22,18 @@ makedepends="
ki18n-dev
kiconthemes-dev
kio-dev
+ kirigami-addons-dev
knotifications-dev
kwidgetsaddons-dev
kwindowsystem-dev
- plasma-framework-dev
- qt5-qtbase-dev
- qt5-qtdeclarative-dev
+ libplasma-dev
+ qt6-qtbase-dev
+ qt6-qtdeclarative-dev
samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/print-manager-$pkgver.tar.xz"
subpackages="$pkgname-lang"
-options="!check" # No tests available
+_repo_url="https://invent.kde.org/utilities/print-manager.git"
+source="https://download.kde.org/stable/plasma/$pkgver/print-manager-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
@@ -41,8 +44,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -50,5 +52,5 @@ package() {
}
sha512sums="
-83c6d97206e5866e8558b33cdbeeca884791bf8fa0964240e68e08b97a3d0e7b6830e5f2f1d1eb7dc9f369670a5c2f2e39da97a15e6817e025e952fd4f51333c print-manager-22.04.0.tar.xz
+fd1d5e1c1cb26838e0b5b98ade3f703425caa6a86b6184af508df4adeaa2521980546a20362e0f2f55d6e968b1f7c24c663a3e0754403977d457860f86885855 print-manager-6.0.4.tar.xz
"