aboutsummaryrefslogtreecommitdiffstats
path: root/community/prosody/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/prosody/APKBUILD')
-rw-r--r--community/prosody/APKBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/community/prosody/APKBUILD b/community/prosody/APKBUILD
index 89606532f4e..fd3148845e2 100644
--- a/community/prosody/APKBUILD
+++ b/community/prosody/APKBUILD
@@ -2,22 +2,22 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
_luaver=5.2
pkgname=prosody
-pkgver=0.10.2
-pkgrel=2
+pkgver=0.11.2
+pkgrel=0
pkgdesc="Lua based Jabber/XMPP server"
url="http://prosody.im/"
arch="all"
license="MIT"
depends="lua${_luaver}-socket lua${_luaver}-expat lua${_luaver}-filesystem
- lua${_luaver}-sec lua${_luaver} lua"
+ lua${_luaver}-sec lua${_luaver} lua${_luaver}-busted lua${_luaver}"
makedepends="linux-headers lua${_luaver}-dev libidn-dev openssl-dev"
+checkdepends="lua-busted"
install="prosody.pre-install"
subpackages="$pkgname-doc $pkgname-openrc"
pkgusers="prosody"
pkggroups="prosody"
source="https://prosody.im/downloads/source/$pkgname-$pkgver.tar.gz
prosody.cfg.lua.patch
- mallinfo.patch
$pkgname.initd
"
@@ -32,7 +32,8 @@ build() {
--with-lua-lib=/usr/lib \
--with-lua-include=/usr/include \
--lua-version=${_luaver} \
- --no-example-certs
+ --no-example-certs \
+ --runwith=lua${_luaver}
# Don't generate certs
rm -f "$builddir"/certs/Makefile
@@ -41,7 +42,7 @@ build() {
check() {
cd "$builddir"
- make test
+ /usr/bin/lua${_luaver} /usr/bin/busted --lua=/usr/bin/lua${_luaver}
}
package() {
@@ -55,7 +56,6 @@ package() {
install -D -m755 "$srcdir"/"$pkgname".initd "$pkgdir"/etc/init.d/"$pkgname"
}
-sha512sums="9fc05e34b45b0c16835ba94a73532fb3b4ee335f27d56bb9260e1b3e22614f89f44eb5d04b4e90d016db0b5bee6f5c7e7d099e1defb027e6823ee7667c1fe28f prosody-0.10.2.tar.gz
+sha512sums="22e55a551a40c92f38a1ed1de5fdcad574d699d58c2e27f93c3d465b55487b8e923c2ba088daf93c7140cbafb0d429687e0b662c8bb1c1aba4b79ac1ea271cd1 prosody-0.11.2.tar.gz
a6ca168fe3d11ee3b05295fb36dfaf8240c60a85507032b2502f9a97d3fd055f7eee38ba6efbb8f79472fc7cdd3556922194d0bd7099f7fb809be01890acc511 prosody.cfg.lua.patch
-b07498cd42677d09f1a3fd4a5d91a085e90dd10cee7d6ee7c5e41438cfc2f4049ab9948c0fd0f7e148dd81f6a25c64c6ae832ea4864cee2329d3c6735216b78b mallinfo.patch
24360603dbd5d2a92758e6c4b4aab4f02cbd05373580cba2df76df98b6045891e8108e8c2d16af9508e93968ed5880db952e7a21b2742ebeec6f14b167968c2c prosody.initd"