aboutsummaryrefslogtreecommitdiffstats
path: root/community/pueue/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/pueue/APKBUILD')
-rw-r--r--community/pueue/APKBUILD55
1 files changed, 35 insertions, 20 deletions
diff --git a/community/pueue/APKBUILD b/community/pueue/APKBUILD
index 2338affd313..cd53c318a30 100644
--- a/community/pueue/APKBUILD
+++ b/community/pueue/APKBUILD
@@ -1,45 +1,60 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=pueue
-pkgver=1.0.3
+pkgver=3.4.0
pkgrel=0
pkgdesc="Manage your shell commands"
url="https://github.com/nukesor/pueue"
-arch="x86_64 armv7 armhf aarch64 x86 ppc64le" # limited by rust/cargo
-arch="$arch !ppc64le" # Fails to build 'ring v0.16.19'
+# s390x: fails to build nix crate
+arch="all !s390x"
license="MIT"
checkdepends="bash"
-makedepends="cargo"
-source="https://github.com/Nukesor/pueue/archive/v$pkgver/$pkgname-$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-$pkgver"
+makedepends="cargo cargo-auditable"
+subpackages="
+ $pkgname-bash-completion
+ $pkgname-fish-completion
+ $pkgname-zsh-completion
+ "
+source="https://github.com/Nukesor/pueue/archive/v$pkgver/pueue-$pkgver.tar.gz
+ fix-process_helper-tests.patch
+ "
+# FIXME: built with current rust, a testcase segfaults..
+options="net !check"
+
prepare() {
default_prepare
- # Optimize binary for size.
- cat >> Cargo.toml <<-EOF
-
- [profile.release]
- codegen-units = 1
- lto = true
- opt-level = "z"
- panic = "abort"
- EOF
+ cargo fetch --target="$CTARGET" --locked
}
build() {
- cargo build --release --locked
+ cargo auditable build --release --frozen
+
+ mkdir -p target/completion
+ local sh; for sh in bash fish zsh; do
+ ./target/release/pueue completions $sh target/completion/
+ done
}
check() {
- cargo test --locked
+ # test_multiple_worker - fails on CI, but passes locally
+ cargo test --frozen -- \
+ --skip daemon::integration::worker_environment_variables::test_multiple_worker
}
package() {
- cargo install --locked --path . --root="$pkgdir/usr"
- rm "$pkgdir"/usr/.crates*
+ cd target
+
+ install -D -m755 release/pueue -t "$pkgdir"/usr/bin/
+ install -D -m755 release/pueued -t "$pkgdir"/usr/bin/
+
+ install -D -m644 completion/$pkgname.bash "$pkgdir"/usr/share/bash-completion/completions/$pkgname
+ install -D -m644 completion/*.fish -t "$pkgdir"/usr/share/fish/vendor_completions.d/
+ install -D -m644 completion/_* -t "$pkgdir"/usr/share/zsh/site-functions/
}
sha512sums="
-20df0b3c5ea54cf8c1403047f5f5b8988dfd3d4e93ed70601b385128e80e55ad72193462d7ebfcda1bd2073c86ac68dff292c14851d08b0b5c8afd93d6937516 pueue-1.0.3.tar.gz
+7fe10957b5e25faec581942761625736f6e3bb9db71fdacd21040435fd300e6718e54cbc25f1e9fe055c01a67b18941b1911f7faab6d4a83eac45fb4feb146eb pueue-3.4.0.tar.gz
+a0d855a6353b74babb67c17c496821d0aecf6bea831fa94c4a2b41af08e5d4e80a616b8c9e08989080f44e972cb67b59719431561b1f359471f26c642287a34f fix-process_helper-tests.patch
"