aboutsummaryrefslogtreecommitdiffstats
path: root/community/pueue/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/pueue/APKBUILD')
-rw-r--r--community/pueue/APKBUILD60
1 files changed, 60 insertions, 0 deletions
diff --git a/community/pueue/APKBUILD b/community/pueue/APKBUILD
new file mode 100644
index 00000000000..cd53c318a30
--- /dev/null
+++ b/community/pueue/APKBUILD
@@ -0,0 +1,60 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=pueue
+pkgver=3.4.0
+pkgrel=0
+pkgdesc="Manage your shell commands"
+url="https://github.com/nukesor/pueue"
+# s390x: fails to build nix crate
+arch="all !s390x"
+license="MIT"
+checkdepends="bash"
+makedepends="cargo cargo-auditable"
+subpackages="
+ $pkgname-bash-completion
+ $pkgname-fish-completion
+ $pkgname-zsh-completion
+ "
+source="https://github.com/Nukesor/pueue/archive/v$pkgver/pueue-$pkgver.tar.gz
+ fix-process_helper-tests.patch
+ "
+# FIXME: built with current rust, a testcase segfaults..
+options="net !check"
+
+
+prepare() {
+ default_prepare
+
+ cargo fetch --target="$CTARGET" --locked
+}
+
+build() {
+ cargo auditable build --release --frozen
+
+ mkdir -p target/completion
+ local sh; for sh in bash fish zsh; do
+ ./target/release/pueue completions $sh target/completion/
+ done
+}
+
+check() {
+ # test_multiple_worker - fails on CI, but passes locally
+ cargo test --frozen -- \
+ --skip daemon::integration::worker_environment_variables::test_multiple_worker
+}
+
+package() {
+ cd target
+
+ install -D -m755 release/pueue -t "$pkgdir"/usr/bin/
+ install -D -m755 release/pueued -t "$pkgdir"/usr/bin/
+
+ install -D -m644 completion/$pkgname.bash "$pkgdir"/usr/share/bash-completion/completions/$pkgname
+ install -D -m644 completion/*.fish -t "$pkgdir"/usr/share/fish/vendor_completions.d/
+ install -D -m644 completion/_* -t "$pkgdir"/usr/share/zsh/site-functions/
+}
+
+sha512sums="
+7fe10957b5e25faec581942761625736f6e3bb9db71fdacd21040435fd300e6718e54cbc25f1e9fe055c01a67b18941b1911f7faab6d4a83eac45fb4feb146eb pueue-3.4.0.tar.gz
+a0d855a6353b74babb67c17c496821d0aecf6bea831fa94c4a2b41af08e5d4e80a616b8c9e08989080f44e972cb67b59719431561b1f359471f26c642287a34f fix-process_helper-tests.patch
+"