aboutsummaryrefslogtreecommitdiffstats
path: root/community/pugixml/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/pugixml/APKBUILD')
-rw-r--r--community/pugixml/APKBUILD22
1 files changed, 12 insertions, 10 deletions
diff --git a/community/pugixml/APKBUILD b/community/pugixml/APKBUILD
index 930106fc710..6fe912edce7 100644
--- a/community/pugixml/APKBUILD
+++ b/community/pugixml/APKBUILD
@@ -1,27 +1,29 @@
-# Contributor: Kevin Daudt <ops@ikke.info>
-# Maintainer: Kevin Daudt <ops@ikke.info>
+# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
pkgname=pugixml
-pkgver=1.10
-pkgrel=1
+pkgver=1.14
+pkgrel=0
pkgdesc="Light-weight, simple and fast XML parser for C++ with XPath support"
-url="http://pugixml.org"
+options="!check" # No testsuite
+url="https://pugixml.org"
arch="all"
license="MIT"
makedepends="cmake"
subpackages="$pkgname-dev"
-source="http://github.com/zeux/pugixml/releases/download/v$pkgver/pugixml-$pkgver.tar.gz"
+source="https://github.com/zeux/pugixml/releases/download/v$pkgver/pugixml-$pkgver.tar.gz"
build() {
- cmake \
+ cmake -B build \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_SHARED_LIBS=True \
-DCMAKE_BUILD_TYPE=None
- make
+ cmake --build build
}
package() {
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="bfc80661005d0a0fb82ca6d5299e5efdd1bb468e11ee52d7ee9367e15776d28efb60266ce03842715cd43aae023afc2b369797bb3cbecd6d6a65c3ae3903e469 pugixml-1.10.tar.gz"
+sha512sums="
+e94e3ea2bdfbe494343f1f5f54057ad3af1b3e0d76b6283051bf020ff64dd9975aa8782d7c34d8bfb42aabcb496e534130c3f9ee127da121cf390473d41e8c4d pugixml-1.14.tar.gz
+"