aboutsummaryrefslogtreecommitdiffstats
path: root/community/pulseaudio-qt/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/pulseaudio-qt/APKBUILD')
-rw-r--r--community/pulseaudio-qt/APKBUILD32
1 files changed, 18 insertions, 14 deletions
diff --git a/community/pulseaudio-qt/APKBUILD b/community/pulseaudio-qt/APKBUILD
index f5494bae7e7..6215d2da466 100644
--- a/community/pulseaudio-qt/APKBUILD
+++ b/community/pulseaudio-qt/APKBUILD
@@ -1,31 +1,36 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-other
pkgname=pulseaudio-qt
-pkgver=1.3
-pkgrel=0
-arch="all !armhf" # armhf blocked by qt5-qtdeclarative
+pkgver=1.4.0
+pkgrel=1
+# armhf blocked by extra-cmake-modules
+arch="all !armhf"
url="https://invent.kde.org/libraries/pulseaudio-qt"
pkgdesc="Pulseaudio bindings for Qt"
license="LGPL-2.1-only OR LGPL-3.0-only"
depends_dev="
glib-dev
pulseaudio-dev
- qt5-qtbase-dev
- qt5-qtdeclarative-dev
+ qt6-qtbase-dev
+ qt6-qtdeclarative-dev
"
makedepends="$depends_dev
doxygen
extra-cmake-modules
graphviz
- qt5-qttools-dev
+ qt6-qttools-dev
+ samurai
"
-checkdepends="qt5-qtdeclarative-dev"
-source="https://download.kde.org/stable/pulseaudio-qt/pulseaudio-qt-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc"
+_repo_url="https://invent.kde.org/libraries/pulseaudio-qt.git"
+source="https://download.kde.org/stable/pulseaudio-qt/pulseaudio-qt-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -DBUILD_WITH_QT6=ON -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_QCH=ON
@@ -33,8 +38,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -42,5 +46,5 @@ package() {
}
sha512sums="
-2326277fd37327db29a5984056949fcf935c36e7b39184d1307a5d0a891efed4f0e4f32e783f3f7da2c7e6b7409eb908b2521064c6d24a28561ed38db9f8d4e8 pulseaudio-qt-1.3.tar.xz
+4bd7d0d50c4720fea59dd7216116de370ea34790c18f80ad01d61c24df5e2b8ee3aa4ddbfa6c19efb0580db6f2089588ecf8cc234ee887fe3d05105b2e63aec3 pulseaudio-qt-1.4.0.tar.xz
"