aboutsummaryrefslogtreecommitdiffstats
path: root/community/pulseaudio/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/pulseaudio/APKBUILD')
-rw-r--r--community/pulseaudio/APKBUILD37
1 files changed, 16 insertions, 21 deletions
diff --git a/community/pulseaudio/APKBUILD b/community/pulseaudio/APKBUILD
index 70aaa02d9bf..3f7cbbc4538 100644
--- a/community/pulseaudio/APKBUILD
+++ b/community/pulseaudio/APKBUILD
@@ -3,9 +3,9 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
# Contributor: Antoine Fontaine <antoine.fontaine@epfl.ch>
-# Maintainer:
+# Maintainer: Krassy Boykinov <kboykinov@teamcentrixx.com>
pkgname=pulseaudio
-pkgver=16.1
+pkgver=17.0
pkgrel=0
pkgdesc="featureful, general-purpose sound server"
provider_priority=10
@@ -33,7 +33,7 @@ makedepends="
sbc-dev
fftw-dev
jack-dev
- openssl1.1-compat-dev
+ openssl-dev>3
speexdsp-dev
eudev-dev
libcap-dev
@@ -46,7 +46,7 @@ makedepends="
gstreamer-dev
gst-plugins-base-dev
"
-depends_openrc="alsa-utils-openrc"
+depends_openrc="alsa-utils alsa-utils-openrc"
subpackages="
$pkgname-dev
$pkgname-doc
@@ -66,22 +66,14 @@ subpackages="
install="pulseaudio.post-install"
source="https://freedesktop.org/software/pulseaudio/releases/pulseaudio-$pkgver.tar.xz
link-libintl.patch
+ remove-once-test.patch
$pkgname.initd
$pkgname.confd
"
case "$CARCH" in
- aarch64|armv7|armhf|x86|ppc64le)
- options="$options !check" # once-test fails, all others pass
- ;;
- s390x)
- options="$options !check" # mix-test fails, all others pass
- ;;
-esac
-
-case "$CARCH" in
- x86|x86_64|aarch64)
- makedepends="$makedepends webrtc-audio-processing-dev"
+ x86|x86_64|aarch64|armhf|armv7|riscv64)
+ makedepends="$makedepends webrtc-audio-processing-1-dev"
_webrtc_aec="enabled"
;;
* )
@@ -98,9 +90,10 @@ prepare() {
build() {
abuild-meson \
+ -Db_lto=true \
-Dgcov=false \
-Dman=true \
- -Dtests=true \
+ -Dtests="$(want_check && echo true || echo false)" \
-Dsystem_user=pulse \
-Dsystem_group=pulse \
-Ddatabase=tdb \
@@ -131,11 +124,12 @@ build() {
-Ddoxygen=false \
-Dstream-restore-clear-old-devices=true \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ XDG_RUNTIME_DIR="$(mktemp -d)" \
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
@@ -194,7 +188,6 @@ bluez() {
alsa() {
pkgdesc="Pulseaudio ALSA support"
install_if="$pkgname=$pkgver-r$pkgrel alsa-lib"
- provider_priority=10 # highest (other provider is pipewire-pulse)
amove usr/lib/pulseaudio/modules/*alsa*.so
}
@@ -203,6 +196,7 @@ utils() {
pkgdesc="Pulseaudio utilities"
amove usr/bin/pa*
+ amove usr/bin/start-pulseaudio-x11
}
jack() {
@@ -229,8 +223,9 @@ equalizer() {
}
sha512sums="
-33b0b4292f05e0882f3ec822cf5720414bb34c523d80fe287b9740d6be219787c562e8024c9b0d9e2ee010771ca72c7ae4f27df1bbef9c9cb6bb6a23cbcc412f pulseaudio-16.1.tar.xz
+be0aec46204d9c9188a796fbe41b4cf6f0f5e6b16fa08ce359b8f0f51253f0ade364b89448bbf5faa2af7e59deb6c72194734c3233944250dcfd4f31968a5e97 pulseaudio-17.0.tar.xz
2c31c5bc592e748248215f8f62f85687cfec230b05f65441e6dafa5fa77d4967e97636209b2011a4501ed1337ecd880b264baa175586fc85183a980846cb8146 link-libintl.patch
-34fe54ece5df60ce63a7955cd828a2716670fef71f40960698ae5518fdaf9cd599f4d8f8852e2c88d715600a9ad06a38984415e5eb320071012e5eb6e5c1b8b1 pulseaudio.initd
+c1223cf42538d91f31dbcb1a167537a1d3b6e8a3bf1b454cdebf95c25ca6f3b444848e9d546f092988851f71fe2c9dd9c4a781a58795e2f57d98563963a4630a remove-once-test.patch
+d3a95453361d4b12e2d4df73a72bbdc9343e2a46e8f5f3aac07b3cb1f9e016fd89816745f485468d144911900a2b38741a371f91cf08285c4b4988e4403d91a0 pulseaudio.initd
75b54581591519d63a3362b155c0f9b0501a60763ab394693a456c44d0216138cf3a40bdd0f7442028663bc045e9ffee286f8f8eaf2ee3bb17379b43615fee0e pulseaudio.confd
"