aboutsummaryrefslogtreecommitdiffstats
path: root/community/pulsemixer/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/pulsemixer/APKBUILD')
-rw-r--r--community/pulsemixer/APKBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/community/pulsemixer/APKBUILD b/community/pulsemixer/APKBUILD
index 0b18a7323c6..e79e3db86d7 100644
--- a/community/pulsemixer/APKBUILD
+++ b/community/pulsemixer/APKBUILD
@@ -2,22 +2,22 @@
# Maintainer: Minecrell <minecrell@minecrell.net>
pkgname=pulsemixer
pkgver=1.5.1
-pkgrel=1
+pkgrel=5
pkgdesc="CLI and curses mixer for PulseAudio"
url="https://github.com/GeorgeFilipkin/pulsemixer"
arch="noarch"
license="MIT"
depends="python3 libpulse"
-makedepends="py3-setuptools"
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
source="$pkgname-$pkgver.tar.gz::https://github.com/GeorgeFilipkin/pulsemixer/archive/$pkgver.tar.gz"
options="!check" # No tests upstream
build() {
- python3 setup.py build
+ gpep517 build-wheel --wheel-dir .dist --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" .dist/*.whl
}
sha512sums="c07b5e5fffa71ca60ed41e4c28a0f4ae5c8b5df9f269ea7376ed835b35536300f34504da724899bab5277f0c39a4c345654b99930ec8bdf4b43374d9b6d331be pulsemixer-1.5.1.tar.gz"