aboutsummaryrefslogtreecommitdiffstats
path: root/community/pup/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/pup/APKBUILD')
-rw-r--r--community/pup/APKBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/community/pup/APKBUILD b/community/pup/APKBUILD
new file mode 100644
index 00000000000..0096dfe7e03
--- /dev/null
+++ b/community/pup/APKBUILD
@@ -0,0 +1,48 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Maintainer: Erwan Rouchet <lucidiot@brainshit.fr>
+pkgname=pup
+pkgver=0.4.0
+pkgrel=23
+pkgdesc="HTML parser for the command line"
+url="https://github.com/ericchiang/pup"
+arch="all"
+license="MIT"
+makedepends="go"
+subpackages="$pkgname-doc"
+source="https://github.com/ericchiang/pup/archive/v$pkgver/pup-$pkgver.tar.gz"
+builddir="$srcdir/src/github.com/ericchiang/pup"
+
+export GOPATH="$srcdir"
+export GO111MODULE=off
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
+
+prepare() {
+ default_prepare
+ cd "$srcdir"
+ mkdir -p "$(dirname "$builddir")"
+ ln -s "$srcdir/$pkgname-$pkgver" "$builddir"
+}
+
+build() {
+ go build
+}
+
+check() {
+ go test ./...
+}
+
+package() {
+ install -Dm755 $pkgname \
+ "$pkgdir"/usr/bin/$pkgname
+ install -Dm644 README.md \
+ "$pkgdir"/usr/share/doc/$pkgname/README.md
+}
+
+cleanup_srcdir() {
+ go clean -modcache
+ default_cleanup_srcdir
+}
+
+sha512sums="5228a283cdbc6425888b08154873e059f5808efd68eb86880d15572398e50b0a431922e6ef5e6acf04bc18c95bfd793590d5df2eccb9a041a64dc03731ec1874 pup-0.4.0.tar.gz"