aboutsummaryrefslogtreecommitdiffstats
path: root/community/pushgateway/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/pushgateway/APKBUILD')
-rw-r--r--community/pushgateway/APKBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/community/pushgateway/APKBUILD b/community/pushgateway/APKBUILD
index 4e9128f09ea..727831e3f9c 100644
--- a/community/pushgateway/APKBUILD
+++ b/community/pushgateway/APKBUILD
@@ -1,11 +1,11 @@
-# Maintainer: Drew DeVault <sir@cmpwn.com>
+# Maintainer: Will Sinatra <wpsinatra@gmail.com>
pkgname=pushgateway
-pkgver=1.4.3
-pkgrel=0
+pkgver=1.7.0
+pkgrel=1
pkgdesc="Prometheus push acceptor for ephemeral and batch jobs"
url="https://github.com/prometheus/pushgateway"
license="Apache-2.0"
-arch="all !riscv64" # limited by nodejs/yarn
+arch="all"
install="pushgateway.pre-install"
makedepends="go yarn bash"
source="
@@ -16,12 +16,16 @@ source="
subpackages="$pkgname-openrc"
options="!check" # Broken by integrations we don't care about
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
+
build() {
go mod vendor
go build \
-trimpath \
-mod=vendor \
- -ldflags "-extldflags $LDFLAGS"
+ -ldflags "-extldflags \"$LDFLAGS\""
}
check() {
@@ -38,7 +42,7 @@ package() {
}
sha512sums="
-e41b8cf89c55569d47fae43310e88e548dfa5b598d1d282ae302844444cd1f7d64b7551763dd34aaca16c1807b232861e423caa15ced63599b95a87c78c14a98 pushgateway-1.4.3.tar.gz
+9f96d61be352b476984a0b1d933745a84a5ec1dbbc106cc16b9485d7581b5ddde10f024c2b130b95c1522e1be3706814edce1f7d6c720d32a8a20b5ffeee8315 pushgateway-1.7.0.tar.gz
39b797f6a38b02f84f94cfdbc5c860af060b044eaf98d7ec99909c4abcb9bf6112755bbd21460bfda9825b31715e403fedb6c88158072cd79d985429bcb5cf01 pushgateway.confd
8dec09ad9b420da54f6f9434307c07d905c4bb17c2bc68fc4863e2bc2288ae1c8faf5757485ad4b0ebb89a78e907f6ccaf11f8379e8ab71e5e88f7c741657f6f pushgateway.initd
"