aboutsummaryrefslogtreecommitdiffstats
path: root/community/pushgateway/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/pushgateway/APKBUILD')
-rw-r--r--community/pushgateway/APKBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/community/pushgateway/APKBUILD b/community/pushgateway/APKBUILD
index 8595c8cf8b2..f7dc185a350 100644
--- a/community/pushgateway/APKBUILD
+++ b/community/pushgateway/APKBUILD
@@ -1,11 +1,11 @@
-# Maintainer: Drew DeVault <sir@cmpwn.com>
+# Maintainer: Will Sinatra <wpsinatra@gmail.com>
pkgname=pushgateway
-pkgver=1.4.2
-pkgrel=4
+pkgver=1.8.0
+pkgrel=0
pkgdesc="Prometheus push acceptor for ephemeral and batch jobs"
url="https://github.com/prometheus/pushgateway"
license="Apache-2.0"
-arch="all !riscv64" # limited by nodejs/yarn
+arch="all"
install="pushgateway.pre-install"
makedepends="go yarn bash"
source="
@@ -16,12 +16,16 @@ source="
subpackages="$pkgname-openrc"
options="!check" # Broken by integrations we don't care about
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
+
build() {
go mod vendor
go build \
-trimpath \
-mod=vendor \
- -ldflags "-extldflags $LDFLAGS"
+ -ldflags "-extldflags \"$LDFLAGS\""
}
check() {
@@ -38,7 +42,7 @@ package() {
}
sha512sums="
-7b1da7eecf03c4f7b493d025920e93c52333becf7da6a2d7bdd0eb6f9a2a4a5d08b00786d0796682a465d84750e2c8092cdb1c4ca59a08f15b8b586d6eaa5f1a pushgateway-1.4.2.tar.gz
+cc09685da2c694e2a826dab40af4f8eb299ff88d10574152e6ebd0a35fb3c946a40b75618db17c9d8e43b5940b067be76880bb91ffbfa948cb828fda3d965186 pushgateway-1.8.0.tar.gz
39b797f6a38b02f84f94cfdbc5c860af060b044eaf98d7ec99909c4abcb9bf6112755bbd21460bfda9825b31715e403fedb6c88158072cd79d985429bcb5cf01 pushgateway.confd
8dec09ad9b420da54f6f9434307c07d905c4bb17c2bc68fc4863e2bc2288ae1c8faf5757485ad4b0ebb89a78e907f6ccaf11f8379e8ab71e5e88f7c741657f6f pushgateway.initd
"