aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-greenlet
diff options
context:
space:
mode:
Diffstat (limited to 'community/py-greenlet')
-rw-r--r--community/py-greenlet/APKBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/community/py-greenlet/APKBUILD b/community/py-greenlet/APKBUILD
index 21c8b3d37dd..ef0fd9258aa 100644
--- a/community/py-greenlet/APKBUILD
+++ b/community/py-greenlet/APKBUILD
@@ -19,14 +19,20 @@ builddir="$srcdir/$_pkgname-$pkgver"
build() {
cd "$builddir"
export CFLAGS="-O0" CPPFLAGS="-O0" CXXFLAGS="-O0"
- python2 setup.py build || return 1
- python3 setup.py build || return 1
+ python2 setup.py build
+ python3 setup.py build
}
package() {
mkdir -p "$pkgdir"
}
+check() {
+ cd "$builddir"
+ python2 setup.py test
+ python3 setup.py test
+}
+
_py() {
local python=$1
pkgdesc="$pkgdesc - $python"