aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-natsort
diff options
context:
space:
mode:
Diffstat (limited to 'community/py-natsort')
-rw-r--r--community/py-natsort/APKBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/community/py-natsort/APKBUILD b/community/py-natsort/APKBUILD
new file mode 100644
index 00000000000..31362e3a21e
--- /dev/null
+++ b/community/py-natsort/APKBUILD
@@ -0,0 +1,47 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-natsort
+_pkgname=natsort
+pkgver=5.0.1
+pkgrel=0
+pkgdesc="A module for natural sorting"
+url="https://github.com/SethMMorton/natsort"
+arch="noarch"
+license="MIT"
+makedepends="python2-dev python3-dev py-setuptools"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py build || return 1
+ python3 setup.py build || return 1
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ _py python2
+}
+
+_py3() {
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+md5sums="e82b8f60b07c6906c2983c40790c6f46 natsort-5.0.1.tar.gz"
+sha256sums="4ad6b4d1153451e345967989bd3ca30abf33f615b116eeadfcc51a456e6974a9 natsort-5.0.1.tar.gz"
+sha512sums="a183558b8a4be6300400b2efed901fb515efce4bb340b3bdda723f6a628aa05ad2f9e1f2c696afa3970e0c82aca47ea597985a1c6c971517ee3bf759f25241bd natsort-5.0.1.tar.gz"