aboutsummaryrefslogtreecommitdiffstats
path: root/community/py2-setuptools/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py2-setuptools/APKBUILD')
-rw-r--r--community/py2-setuptools/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/community/py2-setuptools/APKBUILD b/community/py2-setuptools/APKBUILD
new file mode 100644
index 00000000000..6e82df39f9e
--- /dev/null
+++ b/community/py2-setuptools/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Andrew Manison <amanison@anselsystems.com>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py2-setuptools
+_pkgname=${pkgname#py2-}
+pkgver=44.0.0
+pkgrel=0
+pkgdesc="Collection of enhancements to the Python2 distutils"
+url="https://pypi.python.org/pypi/setuptools"
+arch="noarch"
+license="MIT"
+depends="python2"
+options="!check" #no testsuite
+source="$_pkgname-$pkgver.tar.gz::https://github.com/pypa/$_pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+prepare() {
+ default_prepare
+
+ python2 bootstrap.py
+}
+
+build() {
+ python2 setup.py build
+}
+
+package() {
+ python2 setup.py install --prefix=/usr --root="$pkgdir"
+ # we don't provide a non-suffixed easy_install
+ rm -f "$pkgdir"/usr/bin/easy_install
+}
+
+sha512sums="48febee840612a56c7f4cb0bc3983bf61a6a08c53dfcb95403f6631061481ba391fc0472d608ea6c0078fda8bcc7bb9f6dd8b73d473f5e4349d6eaeb2ab0050b setuptools-44.0.0.tar.gz"