aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-acme/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-acme/APKBUILD')
-rw-r--r--community/py3-acme/APKBUILD45
1 files changed, 32 insertions, 13 deletions
diff --git a/community/py3-acme/APKBUILD b/community/py3-acme/APKBUILD
index 4eeee6b9087..4bb5626d71a 100644
--- a/community/py3-acme/APKBUILD
+++ b/community/py3-acme/APKBUILD
@@ -1,29 +1,48 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=py3-acme
-pkgver=1.4.0
-pkgrel=0
+_pkgname=${pkgname/py3-//}
+pkgver=2.10.0
+pkgrel=1
pkgdesc="ACME protocol implementation in Python"
url="https://github.com/certbot/certbot"
arch="noarch"
-license="Apache"
-depends="py3-setuptools py3-cryptography py3-josepy
- py3-mock py3-openssl py3-pyrfc3339 py3-tz py3-requests
- py3-requests-toolbelt py3-six"
-checkdepends="py3-pytest py3-pytest-runner"
-source="https://pypi.io/packages/source/a/acme/acme-$pkgver.tar.gz"
-builddir="$srcdir/${pkgname/py3-/}-$pkgver"
+license="Apache-2.0"
+depends="
+ py3-cryptography
+ py3-josepy
+ py3-openssl
+ py3-pyrfc3339
+ py3-requests
+ py3-setuptools
+ py3-tz
+ "
+makedepends="
+ py3-gpep517
+ py3-wheel
+ "
+checkdepends="py3-pytest-xdist py3-pytest-runner"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/certbot/certbot/archive/refs/tags/v$pkgver.tar.gz"
+builddir="$srcdir/certbot-$pkgver/$_pkgname"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 setup.py pytest
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest -n auto
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="32398bf5657e997b46699ef0e4bbf2ee81c024556f418251ab44fbf5c8ce39556ebbe8e80045bedee8f5ff5a2084c127338eb69ae842e09bad3ae94f2f16f622 acme-1.4.0.tar.gz"
+sha512sums="
+444981952140376808a9aa475a692df91e60fffc6d45902a3f809bc07311a7d6597ad56e712d3dae234450eb1c735db431182e784bc748511e68bf4f5f2d6cbd py3-acme-2.10.0.tar.gz
+"