aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-aiofiles/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-aiofiles/APKBUILD')
-rw-r--r--community/py3-aiofiles/APKBUILD23
1 files changed, 12 insertions, 11 deletions
diff --git a/community/py3-aiofiles/APKBUILD b/community/py3-aiofiles/APKBUILD
index c83ea185b3d..3131bfaade0 100644
--- a/community/py3-aiofiles/APKBUILD
+++ b/community/py3-aiofiles/APKBUILD
@@ -2,35 +2,36 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=py3-aiofiles
_pkgname=aiofiles
-pkgver=0.8.0
-pkgrel=2
+pkgver=23.2.1
+pkgrel=1
pkgdesc="File support for asyncio"
url="https://github.com/Tinche/aiofiles"
arch="noarch"
license="Apache-2.0"
depends="python3"
-makedepends="py3-build py3-installer py3-poetry-core"
+makedepends="py3-gpep517 py3-hatchling py3-installer"
checkdepends="py3-pytest py3-pytest-asyncio"
+subpackages="$pkgname-pyc"
source="$_pkgname-$pkgver.tar.gz::https://github.com/Tinche/aiofiles/archive/v$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
- # XXX: hack for poetry to not ignore files
- GIT_DIR=. python3 -m build --no-isolation --wheel
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 -m installer -d testenv \
- dist/aiofiles-$pkgver-py3-none-any.whl
- local sitedir="$(python3 -c 'import site;print(site.getsitepackages()[0])')"
- PYTHONPATH="$PWD/testenv/$sitedir" python3 -m pytest
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
python3 -m installer -d "$pkgdir" \
- dist/aiofiles-$pkgver-py3-none-any.whl
+ .dist/*.whl
}
sha512sums="
-4f590baa0369d465a6139c0d4f50beeec60f8f213b607e0e41598f45f507a12edc67b29c77718b03eee7532f10ead8599f55aac3fcb78d0429435c25a58f6d2e aiofiles-0.8.0.tar.gz
+e88bf7901ca54bb57de901863a81f63584ab1a917e311ae5287e9710714a3213151ba3e95640b680a4a288a7e441e6b6e9105214a8a011a6df9e84bd3c701862 aiofiles-23.2.1.tar.gz
"