aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-aiofiles/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-aiofiles/APKBUILD')
-rw-r--r--community/py3-aiofiles/APKBUILD20
1 files changed, 14 insertions, 6 deletions
diff --git a/community/py3-aiofiles/APKBUILD b/community/py3-aiofiles/APKBUILD
index a1a6f97e90e..3131bfaade0 100644
--- a/community/py3-aiofiles/APKBUILD
+++ b/community/py3-aiofiles/APKBUILD
@@ -2,28 +2,36 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=py3-aiofiles
_pkgname=aiofiles
-pkgver=0.6.0
+pkgver=23.2.1
pkgrel=1
pkgdesc="File support for asyncio"
url="https://github.com/Tinche/aiofiles"
arch="noarch"
license="Apache-2.0"
depends="python3"
-makedepends="python3-dev py3-setuptools"
+makedepends="py3-gpep517 py3-hatchling py3-installer"
checkdepends="py3-pytest py3-pytest-asyncio"
+subpackages="$pkgname-pyc"
source="$_pkgname-$pkgver.tar.gz::https://github.com/Tinche/aiofiles/archive/v$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- PYTHONPATH="$builddir"/build/lib pytest
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --root="$pkgdir" --optimize=1
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="2cf9e340eccfef3934bbd86338a235368b99a10e34526e8267232cef14b12e3d79d40350d82874841d5bf7fd0acf779b663288c57d150096f1275586d51583c4 aiofiles-0.6.0.tar.gz"
+sha512sums="
+e88bf7901ca54bb57de901863a81f63584ab1a917e311ae5287e9710714a3213151ba3e95640b680a4a288a7e441e6b6e9105214a8a011a6df9e84bd3c701862 aiofiles-23.2.1.tar.gz
+"