aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-aiohttp-socks/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-aiohttp-socks/APKBUILD')
-rw-r--r--community/py3-aiohttp-socks/APKBUILD22
1 files changed, 15 insertions, 7 deletions
diff --git a/community/py3-aiohttp-socks/APKBUILD b/community/py3-aiohttp-socks/APKBUILD
index 9bee1fc2662..5c866337a98 100644
--- a/community/py3-aiohttp-socks/APKBUILD
+++ b/community/py3-aiohttp-socks/APKBUILD
@@ -1,25 +1,33 @@
# Maintainer: MichaƂ Adamski <michal@ert.pl>
pkgname=py3-aiohttp-socks
-pkgver=0.5.5
-pkgrel=3
+pkgver=0.8.4
+pkgrel=0
pkgdesc="Proxy connector for aiohttp"
url="https://github.com/romis2012/aiohttp-socks"
arch="noarch"
license="Apache-2.0"
depends="python3 py3-aiohttp py3-attrs py3-python-socks"
-makedepends="py3-setuptools"
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/a/aiohttp_socks/aiohttp_socks-$pkgver.tar.gz"
builddir="$srcdir/aiohttp_socks-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 setup.py check
+ # no tests in pypi tarball + they need testing/3proxy to run
+ PYTHONPATH=build/lib python3 -c "import aiohttp_socks"
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="18eb7cb6f8553596e5b973f0bffda71ce67f0b4298ad0006fff5353161ac656a0d87eb138c363683b411a42e2585f308625827bf896bbe53bb5cee2e8901b7a3 aiohttp_socks-0.5.5.tar.gz"
+
+sha512sums="
+6b71661c666c5c76a352c7f1855df9da126174aecf59a295e175eafa8bfb4d077893bffa9b435559a77d74aa698586b8b87bc1b06da1ae057ce2e98f2ef259e7 aiohttp_socks-0.8.4.tar.gz
+"