aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-aiohttp1-cors/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-aiohttp1-cors/APKBUILD')
-rw-r--r--community/py3-aiohttp1-cors/APKBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/community/py3-aiohttp1-cors/APKBUILD b/community/py3-aiohttp1-cors/APKBUILD
index 15b7f0128c5..ce0c864d1b8 100644
--- a/community/py3-aiohttp1-cors/APKBUILD
+++ b/community/py3-aiohttp1-cors/APKBUILD
@@ -2,30 +2,30 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-aiohttp1-cors
_pkgname=aiohttp_cors
-pkgver=0.5.3
-pkgrel=3
+pkgver=0.7.0
+pkgrel=2
pkgdesc="CORS support for aiohttp - 1.x version"
url="https://github.com/aio-libs/aiohttp-cors"
arch="noarch"
license="Apache-2.0"
depends="py3-aiohttp1 !py3-aiohttp-cors"
makedepends="python3-dev py3-setuptools"
+subpackages="$pkgname-pyc"
source="$_pkgname-$pkgver.tar.gz::https://github.com/aio-libs/aiohttp-cors/archive/v$pkgver.tar.gz"
builddir="$srcdir"/aiohttp-cors-$pkgver
check() {
- cd "$builddir"
python3 setup.py check
}
build() {
- cd "$builddir"
- python3 setup.py build || return 1
+ python3 setup.py build
}
package() {
- cd "$builddir"
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="0813ea48de714c85e361dfdaeef1a69526f7446dcc4ce637139cd333dedea58c635f85cfad1c3ccfb0df6e573f0351f282fdbd9726211d5915ed2ba120206b09 aiohttp_cors-0.5.3.tar.gz"
+sha512sums="
+72e0b365b952c08a02c1123d7672cfea01063e2ff01743a71e10f804d22178edc0f1c6b7f87b7ed484ca7c24e89a32de90d0d279f2f5c060427319182f9bdd3b aiohttp_cors-0.7.0.tar.gz
+"