aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-aiorpcx/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-aiorpcx/APKBUILD')
-rw-r--r--community/py3-aiorpcx/APKBUILD18
1 files changed, 12 insertions, 6 deletions
diff --git a/community/py3-aiorpcx/APKBUILD b/community/py3-aiorpcx/APKBUILD
index 826c647ec6a..87ea74dfcac 100644
--- a/community/py3-aiorpcx/APKBUILD
+++ b/community/py3-aiorpcx/APKBUILD
@@ -1,25 +1,31 @@
# Maintainer: MichaƂ Adamski <michal@ert.pl>
pkgname=py3-aiorpcx
-pkgver=0.18.7
-pkgrel=0
+pkgver=0.22.1
+pkgrel=4
pkgdesc="Generic async RPC implementation, including JSON-RPC"
url="https://github.com/kyuupichan/aiorpcX"
arch="noarch"
license="MIT"
depends="python3 py3-websockets"
makedepends="py3-setuptools"
-source="https://files.pythonhosted.org/packages/source/a/aiorpcX/aiorpcX-$pkgver.tar.gz"
+checkdepends="py3-pytest py3-pytest-asyncio"
+subpackages="$pkgname-pyc"
+source="https://github.com/kyuupichan/aiorpcX/archive/refs/tags/$pkgver/py3-aiorcpx-$pkgver.tar.gz"
builddir="$srcdir/aiorpcX-$pkgver"
+options="net" # checks make network requests
build() {
python3 setup.py build
}
check() {
- python3 setup.py check
+ PYTHONPATH=build/lib pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="7d2c3495a4b4cdd1bd91478324685ee8b131a6e3f5f6665324f508e9b211c0ffb6d5590e7fb603f0919724a1983586aeaffd024f95880026baf43d70167a8bf1 aiorpcX-0.18.7.tar.gz"
+
+sha512sums="
+3484da36ce6042d8d4c6b168fd2326c0fc77a825691b95631e54510697708a27ea07e9a808445d504056432adf04f04cb0bc28d4b7194c55c1995096bb938b4d py3-aiorcpx-0.22.1.tar.gz
+"