aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-aiorpcx/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-aiorpcx/APKBUILD')
-rw-r--r--community/py3-aiorpcx/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/community/py3-aiorpcx/APKBUILD b/community/py3-aiorpcx/APKBUILD
new file mode 100644
index 00000000000..87ea74dfcac
--- /dev/null
+++ b/community/py3-aiorpcx/APKBUILD
@@ -0,0 +1,31 @@
+# Maintainer: MichaƂ Adamski <michal@ert.pl>
+pkgname=py3-aiorpcx
+pkgver=0.22.1
+pkgrel=4
+pkgdesc="Generic async RPC implementation, including JSON-RPC"
+url="https://github.com/kyuupichan/aiorpcX"
+arch="noarch"
+license="MIT"
+depends="python3 py3-websockets"
+makedepends="py3-setuptools"
+checkdepends="py3-pytest py3-pytest-asyncio"
+subpackages="$pkgname-pyc"
+source="https://github.com/kyuupichan/aiorpcX/archive/refs/tags/$pkgver/py3-aiorcpx-$pkgver.tar.gz"
+builddir="$srcdir/aiorpcX-$pkgver"
+options="net" # checks make network requests
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ PYTHONPATH=build/lib pytest
+}
+
+package() {
+ python3 setup.py install --skip-build --root="$pkgdir"
+}
+
+sha512sums="
+3484da36ce6042d8d4c6b168fd2326c0fc77a825691b95631e54510697708a27ea07e9a808445d504056432adf04f04cb0bc28d4b7194c55c1995096bb938b4d py3-aiorcpx-0.22.1.tar.gz
+"